Eeschema won't run

Hi Guys,

Please tell me what I’m doing wrong. I’ve just pulled down the latest Windows nightly build (kicad-r10700.829ba2720-x86_64.exe) and installed it as a fresh installation on 2 machines now - my desktop and an i5 laptop. Both host Win 10 Home Single Language OS Build 17134.81.
Install goes fine. When I run KiCad, I get Project Manager as usual - no problems. I create a new project in some folder - no problems. When I try to open Eeshema (schematic), host lingers a while then the app closes - every time. I then try to open Eeschema as a standalone from Start Menu - same thing. I think it’s Windows rejecting because it sees delays.

I’m trying to get a Spice box together and I love KiCad and want the biggest and the best I can pull from it, but this is a stoppage that’s got me pulling my hair out. Please can someone help.


Al from SA.

Obviously it’s a bug, nightly builds are for testing, and very likely to contain bugs. That’s why it is recommended to use stable builds.

I tested that nightly yesterday to confirm fix of a bug I reported, and it was opening and saving a test copy of one of my projects fine.

However we have now entered the beginning of a development cycle and opposed to the nightlies leading up to 5.0 rc3 that were very stable, a lot of commits have already been made to the 6.0 development version recently and more problems are expected early in the cycle. Developers will feel free to make more extensive changes that can break things. Further down the line file format changes are expected that will require even more caution. Thus personally I plan to stay with the stable 5.0x for my main installation for some time forward, and only test the development version in a VM.

1 Like

I’ve been watching the recent development more than I have in the past. It is obvious this recent tag of V5 has changed some things.

I would not recommend using a nightly that is more recent then 5.0.RC3.

1 Like

Yes, while it is not obvious without testing as it is all built from master, the latest 64-bit Windows nightly build that is 5.0 rc3 is kicad-r10615.1a2291879-x86_64 that will show as version: (5.0.0-rc3-dev-14-g1a2291879), release build. The one after that is 6.0 development. Hopefully the final stable 5.0 will be available in a few days, and we will likely get a 5.01 perhaps a month forward to catch up with some fixes for late bug reports that just did not make it into 5.0 stable. Again, I will not recommend the most recent (6.0 development) nightly for anything but testing. My early testing in a VM shows some changes in definition of the 3D models that may initially make them not show up without editing settings.

Edit: Note that I initially had the installation file name above incorrect (my computer mouse has been acting up lately and must have been playing a trick on me when I clicked the file); it has been edited now. The version info was correct.

@AlistairGadd You could try 5.0.0-rc3 from here

Possibly related ? KiCad Crashes Upon Opening Schematic (Solved)

Thanks for that link @bobc. How did you find about it? There is also a sub-folder with patched develop 5.01 versions without libraries included. The last bug I reported (a pretty minor regression) that did not make it into rc3 is fixed there.

I checked this one out and it appears that it is compiled with the action menu turned off. I don’t know if that was intentional or an oversight.

@SembazuruCDE, I compared 5.0.0-rc3-dev-14-g1a2291879 to the patched version (5.0.1-dev-4-g3dcf04fdb), release build, and could not see any missing menu items. The only difference was that when right clicking a footprint the Locking menu item is placed near the top, not further down towards the bottom. Same with the select menu. RC3 from the test folder is similar to rc3 above. With action menu, do you mean the one prompting to clarify selection in PCBNew? I see that in all cases too. I could not see anything missing in Version: (5.0.0), release build in the testing folder either.

@bobc, @Sprig, @otoien, @Gerharddc and @SembazuruCDE, I just want to thank you guys for the assistance. I’ve installed “kicad-5.0.0_rc3-x86_64.exe” and everything seems fine so far when opening new and v4.0.7 projects. Thanks also need to go to all the developers for such a great development tool - I see they were up till 02h40 this morning - the “kicad-5.0.0-x86_64.exe” release is in the “/Windows/testing” directory.

While on that subject - what is the difference between the the “kicad-5.0.0_rc3-x86_64.exe” and “kicad-5.0.0-x86_64.exe” releases - I see that the latter is 210MB bigger?

Best regards,

RC3 is the installer for release candidate 3 (so a pre release. See it as an alpha version)

The one without RCx might be the installer for the first unofficial KiCad 5 release (for testing purposes). My guess is that the later will be used as the official release if no problem with it is found.

Thanks @Rene_Poschl, @bobc, would I be correct in assuming that it would be the preferable one to install?

I am not sure about that. It might just be a test build that has nothing to do with 5.0.0 at all. Wait a few days for the real release. Edit: but then again i do not know anything about that, only what i read here on the forum. (There was some post somewhere that stated that some of these builds where made to test the signing stuff. And as i tagged the libs just a few hours ago i doubt this is the real thing.)

During my testing I noticed that the “kicad-5.0.0-x86_64.exe” release contained the help files which I do not think is included with the other versions.

Thanks @Rene_Poschl and @otoien, I’ll wait a few days for the 5.0.0 release like you suggest.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.