Eeschema "The following libraries were not found"


#1

Hi all. Total noob with first post.
On opening my schematic, I see a message indicating that it has a phantom link to a library for a part that is no longer on the board or on my hard drive. Apparently this is called a ‘stale library reference’. My copy of eeschema does not have the path ‘Preferences > Component Libraries’ so I don’t see how to break this reference. Neither ‘Preferences > Global Libraries’ or ‘Preferences > Project Libraries’ show a link to this part.
I can start a fresh project and recapture my simple board but I am interested to know if this is the only workaround. Please. And thank you.


#2

Your KiCad version? You also didn’t tell how you came to this situation - did you update KiCad or did you move your work to another machine or something else. Give more information.

You may find relevant information from the FAQ, (Start Here) Frequently Asked Questions, especially in Library management in KiCad version 5.


#3

Hi eelik. Thanks for responding.
I’m at 5.1.2 -2 release build.
I updated Kicad and struggled with symbol libraries all on the same machine. On an early version of this design I did have the phantom component placed, but I designed the component out. I deleted the library file because I was trying to keep my project structure simple. Now, I’ve used Library Manager to point to all my needed symbols and am baffled by my inability to use it to break the link to the missing symbol. I see in one of the links you provided that KiCad recommends “Simply delete the library tables from the file system using your operating systems file browser.”. I did that so I am still puzzled why KiCad did not rebuild it’s references to exclude the missing library. Thanks for your patience and assistance.


#4

If your schematic points to a symbol which doesn’t exist in the libraries, it’s not useful to reset the global library tables. I don’t quite understand the problem. I don’t remember seeing words “phantom” or “stale library reference” so I don’t know what they mean. Furthermore, nobody’s copy of eeschema (KiCad v5.1) has “Preferences > Component Libraries” nor “Preferences > Global Libraries” nor “Preferences > Project Libraries”. Eeschema has “Preferences > Manage Symbol Libraries…” dialog with Global and Project Specific Libraries.

If I understood you correctly you have an error message or a warning about a symbol which you don’t see in your schematic at all. It’s a bit difficult to help without seeing the details. At least you could copy the messages verbatim or preferably take screenshots. You can also give your whole project here and someone can check it.


#5

Ah. ‘Phantom’ is my word, for lack of a better way to describe a reference describing a non-existant symbol.
‘Stale library reference’ is a phrase I saw used in another posting that appeared to describe this issue.

“Eeschema has “Preferences > Manage Symbol Libraries…” dialog with Global and Project Specific Libraries.”
You are right there. My bad. My point was (and as you infer) that the widely distributed solution of going to ‘Preferences > Component Libraries’ is useless because that path may have been valid before
V 5.1.2 but it is not valid for V 5.1.2.


I think I stumbled across the problem. I opened my .pro file with a text editor and I saw this after the phrase : [eeschema/libraries]
(…)
LibName33=AD654/ul_AD654JRZ/KiCAD/2019-05-17_05-27-17/2019-05-17_05-27-17
I guess I could hand-edit this out of my .pro file and all would be well?


#6

You can try hand editing (it shouldn’t be necessary to remind about the importance of backups…)

It would be interesting to know how this happened in the first case. In my opinion if files have been edited only through KiCad there should be no situation where a thing is left in a file which gives a dialog every time so that it can’t be fixed through KiCad. But did you check out the project specific library table, does that have this lib?


#7

You can try hand editing (it shouldn’t be necessary to remind about the importance of backups…)
Yup. I backed up my .pro file and deleted the erroneous library citation. Now my schematic opens properly, without the error message. Emboldened, I also deleted the mention of many other libraries which I do not use. Now the file opens much more quickly without errors. Note that I can still select from an enormous variety of parts owing to my inclusion of many symbol libraries under Manage Symbol Libraries. I expect I confused the heck out of eeschema somehow, which caused the orphan library citation to remain in my .pro file. I am really pleased to see the real solution to this problem and happy that I don’t have to recapture my design. Thanks for your help. I really appreciate it.


#8

Forgot to mention that no, the part did not appear in the Project Libraries. Had it been available there, I would not have had this issue. Thanks again!


#9

A kicad version 5 project should not have any library references in the project file itself. This might indicate a failed remap process. Converting KiCad version 4 projects to version 5 (Remap a project)

In version 5 all libraries of a project are defined in the library tables found in the project folder and in the global user settings. (the later hold libraries visible to all projects)
The library tables can be viewed or edited via the managers found in the preferences menu of all kicad windows (only the main window allows accessing both the footprint and symbol lib table editors all other tools only the ones relevant to them.)
KiCad 5 should (after successful remap) only look for libraries in these tables! Meaning if you get a “missing library” reported then it indicates that it is in the library table or the project is not yet remapped.


Additional remark: If you have preferences -> component libraries then you are not using version 5 of kicad. This tool does no longer exist! (replaced with library managers that are used to work with library tables.)


#10

“This might indicate a failed remap process.”
Ah! This is the first I’ve heard of “remapping”!
I followed your link and inferred I could manually recapture my simple V4 schematic into V5 for about 1% of the effort of Remapping. Thank you for that!

“Additional remark: If you have preferences > component libraries then you are not using version 5 of kicad.“
You are right there. My bad. I didn’t mention Library Managers after Preferences though that is the structure in my copy of V5.

Thanks for your help!