EEschema arbitrarily places labels of custom schematic symbol outside of box, contrary to design?!


#1

I just noticed this weird behavior, maybe a but - this is what I’m using, on Ubuntu 14.04:

Application: kicad
Version: (2017-11-13 revision d98fc85)-master, release build
Libraries:
    wxWidgets 3.0.2
    libcurl/7.35.0 OpenSSL/1.0.1f zlib/1.2.8 libidn/1.28 librtmp/2.3
Platform: Linux 4.4.0-104-generic x86_64, 64 bit, Little endian, wxGTK
Build Info:
    wxWidgets: 3.0.2 (wchar_t,wx containers,compatible with 2.8) GTK+ 2.24
    Boost: 1.54.0
    Curl: 7.35.0
    Compiler: GCC 4.8.4 with C++ ABI 1002

Build settings:
    USE_WX_GRAPHICS_CONTEXT=OFF
    USE_WX_OVERLAY=OFF
    KICAD_SCRIPTING=ON
    KICAD_SCRIPTING_MODULES=ON
    KICAD_SCRIPTING_WXPYTHON=ON
    KICAD_SCRIPTING_ACTION_MENU=ON
    BUILD_GITHUB_PLUGIN=ON
    KICAD_USE_OCE=OFF
    KICAD_SPICE=OFF

Basically, I designed a custom schematic symbol, and had its labels placed inside; however, when I place the part, EEschema places these labels outside, for some reason? Here is a complete procedure from scratch, in tutorial form, so you can see what goes wrong:

  • Run Kicad, File / Project…, save as /tmp/aaa;
  • Click “Schematic layout editor” button to open eeschema
  • In Eeschema, click “Library editor - Create / edit components” button

  • In Symbol Library Editor, click “Create new component”

  • In the Component Properties menu, enter Component Name: Grounder, press Ok
  • You get some tiny markings in the center of coordinate system; mouse wheel up to zoom in there;
  • The labels for “Grounder” and “U?” are overlapping:

  • Hover with mouse over “Grounder”, hit ‘M’ on keyboard, move it a bit up; else leave “U?” where it was;
  • Click on “Add pins to component” right toolbar button:

  • In Pin Properties dialog, enter “Pin name”: GND, “Pin number”: 1, “Orientation”: Up, hit OK

  • Move the crosshair with the pin so all is visible, left mouse click to place pin.
  • Again, Click on “Add pins to component” right toolbar button;
  • In Pin Properties dialog, enter “Pin name”: GND, “Pin number”: 2, “Orientation”: Up, hit OK
  • Move the crosshair with the pin so all is visible, left mouse click to place pin
  • Click on “Add graphic rectangle to component body”

  • Move mouse to desired top left edge, left-mouse click there to start rectangle, move pointer to desired bottom right edge, left-mouse click there to end rectangle and place it
  • Click on “Deselect current tool” button in right toolbar, then double click over the rectangle edge
  • In the “Rectangle Drawing Properties” dialog, click “Fill background”, click OK:
  • Click on “Save current component to new library” button in top bar:

  • In the “New Symbol Library” file dialog, navigate to /tmp/aaa, save as aaa_symbols.lib (or just save as /tmp/aaa/aaa_symbols.lib)
  • Get Info: “This library will not be available until it is added to the symbol library table.”
  • Close Symbol Library Editor
  • In Eeschema, click Preferences / Manage Symbol Libraries

  • In Schematic Library Tables, click Project Specific Libraries tab, then click Append Library:
  • In Nickname field, write aaa_symbols; in Library Path write ${KIPRJMOD}/aaa_symbols.lib, Plugin Type: choose “Legacy”, click OK

  • If EEschema closed, start it again from the KiCad button;
  • Click on Place Component button on right bar in Eeschema;
  • With mouse pointer, click in schematic area;
  • In Choose Symbol dialog, click to expand aaa_symbols, and select Grounder there - notice that the preview is exactly the same as the symbol we designed eariler; then click OK:

  • Left-click with mouse in schematic area to place the symbol
  • Mouse wheel up to zoom in at the newly placed symbol:

The labels are placed to the right of the schematic symbol box - not inside it, as it was designed, and as the Choose Symbol showed it ?! :dizzy_face: :angry: :rage:

Why does this happen, and how can I get the symbol to be shown exactly as designed when I place it in a schematic?


#2

Unselect “Automatically place symbol fields” - under General Options, Editing tab.


#3

Many thanks for the quick response, @bobc :

Indeed that was it; just to document more specifically: that option is in EEschema / Preferences / General Options : Schematic Editor Options / Editing tab / Automatically place component fields checkbox :


#4

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.