DXF import problems

New user here. I am using the latest ver of KiCAD (5.1.4-0) on Mac OS 10.12.6. Have not been able to get dxf import to work properly. Followed the directions regarding using LIbreCAD to explode and save as R12 using a dxf file from an enclosure manufacturer but just got a tiny dot on the screen. Then tried recreating the outline file from scratch in LIbreCAD and saving it as R12 dxf but it imports all the layers with dimensions and construction lines and I can’t find a way to just save the drawing layer in LibreCAD, so I’m stuck.

Most likely already answered.

If only a tiny dot was imported, maybe you have a scale conflict (while saving you are setting the scale to small 1:100), try to choose another scale while importing into kicad (maybe huge as a test to see if it helps).


If you are getting other lines in your drawing when you import it, you can cleaning it up by clicking on each line and deleting them if they are a lot this may be tedious, but it may be faster while trying to figure something else out. After all, normally this step will be done a reduced number of times.

Thanks for the reply. Changing the input scale didn’t work with the manufacturer’s file. I recreated the file manually and deleted all the the layers but the board outline, saved it as a dxf 2007 and it imported just fine (although it complains about DL solids not handled something or other). So I can work with this.


I have used 4.x versions of KiCAD (and gEDA before CERN selected KiCAD) in a corporate environment, working in R&D. I had frequent problems with scaling factors when importing DXF files created with “professional” packages like Solidworks. I vaguelly remember from a few years back that a colleague of mine researched the issue and showed me that the DXF file specification allows the user to define units, but in my corporate environment back then all mechanical engineers worked with imperial units, so they never specified units among them. KiCAD, however, assumes (assumed) mm if no units are (were) specified. It has been a few years now, but I remember we looked at a DXF file (generated by another mechanical engineer colleague) with a text editor and he showed me that units were not defined. Granted, that was a few years back and things may have changed since then, but I thought this information may be useful.

Yes, I have been sticking with metric in an attempt to reduce the number of rabbit holes I have to climb out of. Thanks for the background. I think it am pretty close to having it work. Hopefully, I will remember all these suggestions the next time I do this again.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.