Cannot import .dxf file


I am trying to insert an outline to create a footprint, however when I try to import the .dxf file I get this message.
Does anyone know where I enable or download such plugin to handle .dxf files or is my .dxf the error? I created the .dxf from a solidworks part I created.

Thanks in advance!


Dxf format has many versions. Try export is as dxf R12 from some program first.


What is the capitalization of the filename? Did you use .DXF? There is a bug in 5.1.4 on Windows that will only import a dxf file if the extension is all lowercase (so it must be filename.dxf, not filename.DXF). This is fixed in the current 5.1 nightlies, and will be released with 5.1.5.


Thank you so much for your response!!
I tried this and it worked. Much appreciated!

Hi, I checked and it is .dxf (Lowercase). I got it work finally and I am able to import the file now, But this is real good to know. I appreciate your response, Thank you!!!

1 Like

I can confirm that this also a bug in the mac version of KiCad 5.1.4
Changed the case of the suffix in my dxf file and it did import properly after failing with DXF.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.