DRC Errors in PCB editor

Hi. I’m currently designing my very fist board so I don’t have to much experience. However I’m facing some issues with DRC.
Not sure if this info is needed but my 4 layer board stackup is: Signal, Ground, Power (3V3), Signal.

The first issue is that it tells me that I should add a second thermal relief pad. But I didn’t even add a single thermal relief here (see picture. Error is for pad 4 where the red marker is). I have no idea what causes this but I know that I can turn that error off by setting the “min thermal relief spoke count” to 1 inside the “Board Setup” window under “Constraints”. But I guess that this is not the proper way to get rid of this problem.

Since new users apparently can not put two pictures into one post I’ll try to answer to this topic and discuss the second problem and if that doesn’t work I’ll create a new topic for that. Not sure why the forum doesn’t let new users post two pictures in one post.

If anyone could help me out here I would really appreciate that.

The second problem is that I get two “Missing connection between items” warnings. In the picture below I marked the 5V lane so that it is recognized more easily and I put arrows pointing to the “missing connections”. Since the silkscreen is displayed behind the lane, I should mention that the element that is “unconnected” is a ferrite bead. But somehow KiCad wants me to bridge the two pads together. I guess that this is not how a ferrite bead should be connected right?

And the second “Missing connection” warning is between the 5V lane and the 5V pad of the ESD protection IC (USBLC6-2SC6). However I can clearly see that it is connected to the USB 5V pad and therefor should not complain about not being connected to the 5V net.

Have a nice day.

For the first, the clearance of the zone itself is cutting into both of the spokes of the thermal relief and that could be a possible cause. You can try making the zone clearance itself a bit narrower. Another option is to set the pad connection to “None” and then manually draw a track.

For the second, Both sides of the fuse holder are connected to the +5V net. That means your fuse is shorted somehow in the netlist and you have to fix that in the schematic. Maybe you misplaced a power symbol, or you drew a wire right through a schematic symbol (Such as that fuse) and such errors are sometimes hard to spot. You can use the net highlight function as an aid in connectivity check. Same for that other missing connection. I don’t know what sort of SMT part that is right of the fuse (Maybe a ferrite bead?) but KiCad shows the same +5V net on both pads, and that is very likely not correct.

Thanks for the answer. Yes like I mentioned in my previous post it is indeed a ferrite bead.

You are absolutely right about both problems. The first one was easy to fix. I just set the clearance of the power plane to 0.45mm instead of the default 0.5mm. That fixed the issue.

And for the second one: I actually placed some extra 5V symbols into my schematyc. The first one behind the fuse and the second one behind the ferrite bead. This was done because the electric rule check complained if I didn’t do it. No idea why.

Here is a picture of my schematyc. Like I mentioned it’s my very first design that I ever make. I know it is a bit messy. The picture contains all relevant parts. The only things not in the picture are simple IO connections, decoupling capacitors and the crystal for the MCU.

So I guess that I just have net naming issues that causes the two “missing connection” warnings, but the board should work I guess.
Thanks for clearing things up. The electric rule check however complains about pin 3 of the AMS1117 regulator if I don’t have the 5V flag. It says “Input Power pin not driven by any Output Power pins”.

This shows the problem clearly:

In KiCad power symbols work as global labels. And this is normal and expected behavior. For example, pin 2 of your microcontroller is wired to a power symbol, and you expect that pin to be connected to the power supply. But in the same manner, you have connected both sides of the fuse to the power supply too, and that does not work.

Apart from the labeling itself, best I know all power pins of AVR controllers must be connected to the same power supply. Are you sure those power connections are all right? (I do not know the exact chip you are using) (And it’s also off topic for this forum).

This is another issue:

This question has been answered many times on this forum, and it is solved by placing PWR_FLAG symbols on your schematic (Or by disabling this ERC check if you just don’t like it).

ErrType(3): Pin connected to some others pins but no pin to drive it

Thanks a lot again. That explains what is happening here. Jep I could fix it by deleting the added 5V flags and instead use a pwr flag for the AMS1117. I’ll bring it over to the pcb editor tomorrow and try to get it working. Thanks again. The pwr flag really solved that issue.

Hello and welcome @Dignity1337

To help keep spammers under control, new members have to jump through a few hoops to be able to post anything other than one item. Please read the below link:


You still need to open at least three more threads and slowly scroll through twenty posts to be promoted to Basic, after which you may post however many of whatever you wish :smiley:

What does “Open a thread” mean? I interpret that as creating a new topic.

From the link mentioned in jmk’s post:

Get to trust level 1 by…

  • Entering at least 5 topics
  • Reading at least 30 posts
  • Spend a total of 10 minutes reading posts

I am also not very sure what “Entering a topic” means, but I guess that it means to make a post and type some text in a topic.

Enter = Open = Look at = maybe read … intransitive verb : to come or go into.
No creation of anything.

All a new user needs to do is read.
From the Discourse site:

The link at the top of the FAQ to the Discourse site explains the requirements to get to each Level. The above screen-grab is from that link.

Ok quick update. I’ve made the changes and updated the pcb editor. Now everything works as exprected. Thanks for that.

Just one more question: One of the IO connections (8 pin FFC) should later on connect to a second pcb (just a really simple one). This second pcb gets it’s power from the first one through the FFC connector. Since there are no power emitting pins in this schematyc, I’ve also added pwr flags and the electric rule check works well except for ground. If I add a pwr flag for gnd, I get an error because the emitter of an NPN transistor is connected to gnd (Pis of type Power output and Open emitter are connected). Is there any way to fix this error? I meann I could just ignore it because I know that the power connections are fine but just wonder if I can tell this to KiCad somehow?

For me for typical transistor symbol its Emitter should not have Open emitter type.
Where from you have took this symbol? May be someone did it for his untypical purposes.
I have no practice with ERC Error messages as I don’t run ERC.

Indeed. “Open Emittter” pin type implies an ouput pin type for an IC and should not be used for separate transistors. In KiCad’s default libraries (all?) emitters and collectors of regular BJT’s (Inclusive the * 2222 variants) are set to Passive.

Ok that explains it. The symbol is indeed part of KiCad default symbols. I just typed in NPN and it is the first result that shows up (I’m using KiCad 7 if that helps).

But that really seems to be the issue. I now replaced the symbol with a 2N2219 symbol and just renamed it to 2N2222. This solved the issue. I have no idea why the NPN symbol chooses to use other pin types.

So that everything works now I can just say thanks to all (specially paulvdh). Topic can be closed.

EDIT: I just noticed that the description of the NPN symbol states that it should only be uised for simulation. That might have been why the pin types are not passive.

No, it is not. When I look at the screenshot of your Choose Symbol dialog, it is listed in the –Recently Used– category, and this is generated on the fly. If you want to see from which library a particular symbol is, you can hover the mouse cursor over it (No need to click first) and press e to edit it’s properties. Then it shows in the bottom left corner of the properties window. Or use Schematic Editor / Tools / Edit Symbol Library Links to get a table with all used schematic symbols.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.