Display issues in Kicad 5 on Windows


#1

Windows 7 x64 with Intel graphics.

The old OpenGL view with the nice grid seems to have gone. The new line grid mode is solid white lines, no transparency and basically unviewable.

When I enable sub-pixel render the whole display shimmers as I move the mouse. When I select 2x oversampling the display is stable but the aliasing errors look worse than with no anti-aliasing. When I select 4x I get a message about the buffer being too large and then it ignores further attempts to change settings.

When changing display settings the whole app hangs for about 30 seconds. Display quality, grid settings, anything.

I get various WX widgets errors too, such as when trying to open the Preferences menu.


#2

It is not necessaraly a problem with kicad. It could just be that the settings are a bit strange (maybe the default settings are not well suited for you or kicad somehow got strange settings. The later could be the case if you did run a nightly before installing v5)

The grid can be setup at multiple places. You can choose the type (lines, dots or small crosses) in preferences -> preferences -> pcb_new -> display options (can be a bit different for you as i am running a nightly)
In the same menu you can also select the rendered width of the grid. (could also be something that is different compared to the past)

On the right there is also the layer/ items manager. If you switch it to the items view you should see an entry for grid. Middle (or double left click) on the colored square next to it. There you can select a color and maybe more important to you the transparency.


#3

Thanks. I didn’t run the nightlies, just upgraded directly from V4 to V5. I tried fiddling with the grid rendering but couldn’t get it to look like V4, but I’ll keep trying.

The constant exceptions and hangs are a bigger issue. Scrolling doesn’t work properly sometimes either. I hold middle mouse button, it scrolls a few pixels and then stops.

The new output quality seems to be slightly worse than V4, especially with anti-aliasing turned on which just creates lots of aliasing errors. I don’t know if the schematic view is supposed to be anti-aliased, but it isn’t for me. It’s also got the same severe performance issues as V4, like when removing a track connected to a large IC the refresh is incredibly slow for no apparent reason.


#4

Is it possible you are just used to the legacy toolset (in v4 default)?
The current default is the toolset that was previosly known as opengl/cairo. (switching between toolsets is done in the view menu or F9, F11, F12) more details see: Pcb_new: What is a canvas? (default [legacy], open-gl [accelerated] and cairo [fallback]) Is there a difference?

Just a fair warning: the legacy canvas will most likely die sometime during the v6 development cycle. (meaning v6 might not come with it. I would guess that the devs will do everything they can to keep it alive for all v5.x releases.)


#5

I couldn’t see the switching option on the View menu any more, but I did use F9, F11 and F12. Either of the F11 and F12 options had the frequent exceptions and freezes. I’m afraid I’m not sure what mode I was in with the shimmering.

I had to go back to V4 to get some work done. Is it possible to install V5 along side V4?

To be honest the whole upgrade process was a huge pain. Every project had to be converted, and the converter would hang for minutes at a time.


#6

In OpenGL mode on Windows 10 64
Preferences - Display Options - Dots/Lines/Small Crosses

Get the latest V5.0.0 26th July onwards, which fixes a build error causing wxWidgets warnings


#7

It’ in Preferences now. Many things have been moved from one place to another in the UI, you have to get used to the new organization.


#8

Yes, none of them show the lines like the old OpenGL mode from V4, which was easy to see. I think I might need to tweak the colours and transparency but the default settings are really bad.

That’s what I installed, still getting wxWidgets exceptions. For example, in pcbnew when I click on the preferences menu (just to open the menu, not select anything in it) I get an exception. The only way to access the menu is to select “cancel” in the exception to stop it from displaying any more.

*** edit ***

Wait, you mean there is a new 5.0.0 with the same version number as the old 5.0.0 but which was released today?


#9

That has been a major question for a while, spread along many threads. There’s no centralized documentation for that because there just are too many details and possibilities. You have to start with two things:

  1. Your system and platform - it’s different for different systems. For some it may be almost impossible. For others only difficult. Unfortunately (most of) the current packages are not prepared to allow an easy way to do that.

  2. How do you want to use them: 4 for old projects, 5 for new? Do you want to use old libraries for old projects even when you migrate them to v5? Etc.


#10

Windows 7 or 8 x64. Ideally I’d like to keep V4 for old projects, and eventually switch to V5 for new when it becomes stable enough. I guess I’d have to have two copies of all libraries.

It would be really useful to have this feature. It’s common with software development, especially on the embedded side but even on desktop you can have multiple versions of Visual Studio installed to avoid compatibility and upgrade issues.

I tried it out in a Windows 8 VM, the strange corruption and shimmering is still there with subpixel sampling turned on. I thought it might be the Intel graphics driver but this is a VM on a system with an AMD card.


#11

Yes :cry:
You cannot tell which you have from the “About KiCad”


#12

Oh god, really? They couldn’t bump it to 5.0.1?

I think I’ll stick with V4 for a few months at least, until they get a grip on V5.


#13

5.0.1 would imply changes to the source code. No source code has been changed. (It would also mean that all other platforms need to change their version strings as well. Otherwise users will be confused why windows has a newer version of kicad than any other platform)


If you really intent to stick with v4 at least use the backport library of the kicad 5 for new projects. (If you use the official lib) This will make transitioning to v5 a lot easier once you decide to take the plunge.


#14

I’ll look into the backported libraries. The library situation is a bit of a pain, my projects always seem to end up with orphaned symbols and footprints every time I update Kicad, even minor versions.

Stuff like that is why I like to have multiple versions installed.


#15

The goal for the v5 libs is to keep them stable. This will be easier as kicad no longer uses the github plugin by default for footprint libs.


#16

Hello , I’ve updated To V5.0.0 in windows
Wen I ruin first time PCBNEW , Ask if I wnat hardware accelration from my graphic card. I Authorized, , NOW way now it dont show the pcb only text and big squares.
How can I go Back ? Is there an option in menu ?
I’ve reinstalled V5 and the same
Thanks
Luis Dapino


#17

If you ruin pcbnew, it is not strange it will not work :joy:

Now, seriously, are you using an existing board of a previous version layout?
Is your graphic card opengl compatible?
Have you tried F9 to see the layout in the legacy canvas?
Could you send a picture of the layout?


#18

F12 might also be an option (modern toolset without opengl)


#19

Both non-legacy look too dark to me.
So I made them as bright as I could (using the nice change-color… thing) but they are still not bright enough for me.
If I now change to legacy, it’s so bright I get a tan.
Legacy can’t be discontinued while the other modes look like this; please don’t!

Cat


#20

Can you show some screen capture of what you are seeing?