Crosshair missing in v.6.99 and 7.0

I always use full window crosshair in both schematic and PCB editors.
It works fine till the middle of December 2022. The last kicad-nightly version which works fine for me is 202212082203+966f7bfa4c~162~ubuntu20.04.1

Version info:

Application: KiCad
Version: 6.99.0-unknown-966f7bfa4c~162~ubuntu20.04.1, release build
Libraries:
wxWidgets 3.0.4
FreeType 2.10.1
HarfBuzz 2.6.4
FontConfig 2.13.1
libcurl/7.68.0 OpenSSL/1.1.1f zlib/1.2.11 brotli/1.0.7 libidn2/2.2.0 libpsl/0.21.0 (+libidn2/2.2.0) libssh/0.9.3/openssl/zlib nghttp2/1.40.0 librtmp/2.3
Platform: Linux 5.4.0-137-generic x86_64, 64 bit, Little endian, wxGTK, cinnamon, x11
Build Info:
Date: Dec 8 2022 22:03:27
wxWidgets: 3.0.4 (wchar_t,wx containers,compatible with 2.8) GTK+ 3.24
Boost: 1.71.0
OCC: 7.5.2
Curl: 7.68.0
ngspice: 38
Compiler: GCC 9.4.0 with C++ ABI 1013
Build settings:
KICAD_SPICE=ON


In all newer versions the crosshair is missing when rendering engine is set to “Accelerated graphics”. If the engine is switched to “fallback”, the crosshair appears.

System information:

NAME=“Linux Mint”
VERSION=“20.3 (Una)”
ID=linuxmint
ID_LIKE=ubuntu
PRETTY_NAME=“Linux Mint 20.3”
VERSION_ID=“20.3”
HOME_URL=“https://www.linuxmint.com/
SUPPORT_URL=“https://forums.linuxmint.com/
BUG_REPORT_URL=“Linux Mint Troubleshooting Guide — Linux Mint Troubleshooting Guide documentation
PRIVACY_POLICY_URL=“https://www.linuxmint.com/
VERSION_CODENAME=una
UBUNTU_CODENAME=focal

HW info:
Lenovo P51
GPU0 - Nvidia Quadro M2200
NVIDIA Driver Version: 510.108.03

On Windows, the full screen crosshair is working on latest Nightly with accelerated graphics for me

Not confirmed. Works for me, accelerated and fallback.

Application: KiCad PCB Editor x64 on x64

Version: (7.0.0-rc1-145-gbd6d0b6cb6), release build

Libraries:
	wxWidgets 3.2.1
	FreeType 2.12.1
	HarfBuzz 5.0.1
	FontConfig 2.14.1
	libcurl/7.86.0-DEV Schannel zlib/1.2.13

Platform: Windows 11 (build 22621), 64-bit edition, 64 bit, Little endian, wxMSW

Build Info:
	Date: Jan 13 2023 06:49:13
	wxWidgets: 3.2.1 (wchar_t,wx containers)
	Boost: 1.80.0
	OCC: 7.6.2
	Curl: 7.86.0-DEV
	ngspice: 38
	Compiler: Visual C++ 1934 without C++ ABI

Build settings:
	KICAD_SPICE=ON

Probably the problem is with kicad under Linux

Possibly Ubuntu as well as it is fine on gentoo

NOTE: the ubuntu build is using wxwidgets-3.2.1 (but wxpython is compiled against wxwidges-3.0.x) so there might be a clash here

Full window crosshair works in both schematic editor and board editor in fedora 37 Linux, in accelerated graphics mode on Intel UHD graphics 620.

Application: KiCad PCB Editor x86_64 on x86_64

Version: 7.0.0-rc1-1.20230114git00d77f6.fc37, release build

Libraries:
wxWidgets 3.2.1
FreeType 2.12.1
HarfBuzz 5.2.0
FontConfig 2.14.1
libcurl/7.85.0 OpenSSL/3.0.5 zlib/1.2.12 brotli/1.0.9 libidn2/2.3.4 libpsl/0.21.1 (+libidn2/2.3.3) libssh/0.10.4/openssl/zlib nghttp2/1.51.0

Platform: , 64 bit, Little endian, wxGTK, KDE, wayland

Build Info:
Date: Jan 14 2023 18:15:27
wxWidgets: 3.2.1 (wchar_t,wx containers) GTK+ 3.24
Boost: 1.78.0
OCC: 7.5.0
Curl: 7.85.0
ngspice: 38
Compiler: GCC 12.2.1 with C++ ABI 1017

Build settings:
KICAD_SPICE=ON

Full cross working ok with Ubuntu 22.10 (Mate) accelerated graphics with
Advanced Micro Devices, Inc. [AMD/ATI] Ellesmere [Radeon Pro WX 7100 Mobile]

Application: KiCad x86_64 on x86_64
Version: 7.0.0-rc1-unknown-00d77f624a~164~ubuntu22.10.1, release build
Libraries:
    wxWidgets 3.2.1
    FreeType 2.12.1
    HarfBuzz 2.7.4
    FontConfig 2.13.1
    libcurl/7.85.0 OpenSSL/3.0.5 zlib/1.2.11 brotli/1.0.9 zstd/1.5.2 libidn2/2.3.3 libpsl/0.21.0 (+libidn2/2.3.2) libssh/0.9.6/openssl/zlib nghttp2/1.49.0 librtmp/2.3
Platform: Ubuntu 22.10, 64 bit, Little endian, wxGTK, mate, x11
Build Info:
    Date: Jan 14 2023 20:32:53
    wxWidgets: 3.2.1 (wchar_t,wx containers) GTK+ 3.24
    Boost: 1.74.0
    OCC: 7.6.3
    Curl: 7.85.0
    ngspice: 38
    Compiler: GCC 12.2.0 with C++ ABI 1017
Build settings:
    KICAD_USE_EGL=ON
    KICAD_SPICE=ON

something nvidia driver related?

Looks like it.
There is another issue with the Ubuntu build where the wxpython lib isn’t built against xwidgets-3.2 but that is an Ubuntu<>kicad concern

1 Like

Yes, probably this is the reason.
My laptop has a hybrid video and now I switched from Nvidia to Intel HD Graphics with Mesa and crosshair appears!
I’m going to return the system to Nvidia and will check the result.
The strange thing is that with the older 6.99 version I mentioned in the first post, the crosshair is working. Probably some changes in the code after the version 20221208 happened which are Nvidia related broke the crosshair.

A few users reported similar issus but all due to Nvidia

That issue was created in August, long before madrigal experienced problems, and it was also closed again last week on the 2nd of January.

The issue was also created by Karol Harasim while Sébastien reported it worked for him, presumably after an update of his Nvidia drivers.

It’s all quite curious.

There are no crosshairs, either large or small with accelerated graphics in7.0.0-rc1, crosshairs only work with fallback graphics.

All crosshairs work on 6.0.10 with both accelerated or fallback graphics.

Application: KiCad PCB Editor x86_64 on x86_64

Version: 7.0.0-rc1-unknown-f358749b28~164~ubuntu22.04.1, release build

Libraries:
wxWidgets 3.2.1
FreeType 2.11.1
HarfBuzz 2.7.4
FontConfig 2.13.1
libcurl/7.81.0 OpenSSL/3.0.2 zlib/1.2.11 brotli/1.0.9 zstd/1.4.8 libidn2/2.3.2 libpsl/0.21.0 (+libidn2/2.3.2) libssh/0.9.6/openssl/zlib nghttp2/1.43.0 librtmp/2.3 OpenLDAP/2.5.13

Platform: Linux Mint 21, 64 bit, Little endian, wxGTK, cinnamon, x11

Build Info:
Date: Jan 13 2023 20:33:27
wxWidgets: 3.2.1 (wchar_t,wx containers) GTK+ 3.24
Boost: 1.74.0
OCC: 7.5.2
Curl: 7.81.0
ngspice: 38
Compiler: GCC 11.3.0 with C++ ABI 1016

Build settings:
KICAD_USE_EGL=ON
KICAD_SPICE=ONstrong text

I have the same kind of issue. No crosshair whatsoever in eeschema in accelerated graphics with NVIDIA drivers. ( 470.161.03 which are the recommended one for me by Ubuntu)

Work as intended with programmed graphics but not with accelerated.
I tried to disable the cursor HW acceleration on my xorg configuration, but this made my computer unable to reboot. :smiling_face_with_tear: (fortunately, I had backed up the xorg configuration, so no real issue with that)

Might be interresting to note that the crosshair works in accelerated graphics if I fall back to xorg “nouveau” drivers but it is poorly performing, even with regards to NVIDIA drivers and programmed graphics.

Application: KiCad Schematic Editor x86_64 on x86_64

Version: 7.0.0-rc1-unknown-7ab651f078~164~ubuntu22.04.1, release build

Libraries:
	wxWidgets 3.2.1
	FreeType 2.11.1
	HarfBuzz 2.7.4
	FontConfig 2.13.1
	libcurl/7.81.0 OpenSSL/3.0.2 zlib/1.2.11 brotli/1.0.9 zstd/1.4.8 libidn2/2.3.2 libpsl/0.21.0 (+libidn2/2.3.2) libssh/0.9.6/openssl/zlib nghttp2/1.43.0 librtmp/2.3 OpenLDAP/2.5.13

Platform: Ubuntu 22.04.1 LTS, 64 bit, Little endian, wxGTK, ubuntu, x11

Build Info:
	Date: Jan 19 2023 20:33:46
	wxWidgets: 3.2.1 (wchar_t,wx containers) GTK+ 3.24
	Boost: 1.74.0
	OCC: 7.5.2
	Curl: 7.81.0
	ngspice: 38
	Compiler: GCC 11.3.0 with C++ ABI 1016

Build settings:
	KICAD_USE_EGL=ON
	KICAD_SPICE=ON