Could not get RF tools via fence working

Using KiCad 8.1

It is the first time for me to use this plugin, so it might be I am doing something wrong.

Have a filled area attached to net agnd and a trace inside this area. I select the trace, select ‘via fence generator’ set some parameters (offset, drill, via size) which should be valid for the design rules.
input tracks ‘include selected’ and ‘via net’ agnd.

Get the message: “placed 0 fencing vias, please run a DRC”

The only errors from the DRC are some unconnected items.

What can be wrong here, or how to determine why it failed ?

It might well be that this plugin has not been updated to run on KiCad 8. It is a third party offering and during the development phase of a new KiCad version old methods are constantly being removed or refactored. This means that a lot of authors will wait until a new version is fully stable before releasing a new version of their add on rather than trying to rewrite bits every few days.
Have you tried testing a minimal example - a new project with maybe one component and a board edge to see if it is a problem with your project or a more general problem?
In general, it is best to raise these issues with the plug-in author who will appreciate an example to make a good bug report.
Oh and btw there is no KiCad 8.1 - I presume you mean 8.0.1.

I’m not using kv8 atm, but recently someone has made a PR to fix issues on kv8.

So it may work.
Regarding via fencing you may uncheck
Remove vias violating clearance rules
in the dialog.

I tried on kicad v8.01 testing and the latest release of the plugins (via fences) simply works.


thanks to HaydenHu and craftyjon
RF-tools round tracks are also now compatible with kv8


Can they be installed with the KiCad8 plugin manager? Thank you for your excellent work, BTW.

I’ve recently patched almost all the tools, a part a wizard for Arc pads, which is missing because of some SWIG kicad internal issue.

not ATM
you need to install RF-tools with the old method… i.e. cloning the repo in the right plugins folder.
the right place in linux would be: