Copper pour doesn't fill

I have a relatively simple PCB that I’m working on the layout. I have created the edge cut layer (Board outline), have placed most components, done 50% of the routing and when I create the fill area the copper pour doesn’t fill.

I’ve searched the forums, googled and read the documentation on how to create a fill several times and don’t know how to troubleshoot further. I have deleted and recreated the board outline and fill area several times and would like to avoid starting the PCB from scratch if possible.

Here’s some details:

  • Ubuntu 18.04 with Kicad 5.0.0 (recent install with some video issues at first, but seem to be fixed)
  • Schematic has no ERC errors except for a few “undriven pn” errors that I’m ignoring.
  • PCB has no DRC errors except for unconnected traces.
  • Fill area is a ground pour and should cover most of one side of a ~100mm by 50mm board, there are definitely ground pads in the fill area.

Can anyone help me with the next troubleshooting steps?

Could you just give us the whole project?

I’d prefer not to post it publically, but happy to share directly if needed.

I’m in the process of switching from Eagle to Kicad, so not used to kicad files. Can I just send the pcb file?

Have you tried a small test board to reproduce the problem?

Without further detail, I think the usual problems with zone fill are not having a pad with the right net in the zone, and zone display turned off.

It may be enough.

You could also try reducing your board to some minimum where the problem is shown but which doesn’t reveal your whole design and sharing the file here.

I’ve deleted my board, deleted my pour, recreated a smaller board with a single component and it still won’t pour. I’ve verified that the pour is on the right layer, that there is a pad within the layer and I’ve toggled all the zone display settings with no change. What would the next troubleshooting steps be?

In the picture above, edge cuts layer visibility is turned off. Board outline matches pour outline.

KiCad removes unconnected pour areas.
Check the net name of the fill is correct, and try running a track that is GND net, where you know the fill can reach.

I’ve tried both front and back copper for pour and component(smd resistor), 3.3V, GND, running unconnected traces, connected traces and nothing seems to work. The pour visibility is definitely turned on.

Is there a chance that my board layer is incorrect in some way? I created my board by clicking on “edge cuts” and then drawing the outline with the “add graphic polygon tool”. I then lay the pour overtop of this board outline.

Make sure that the footprint Properties and the pad Properties both have Solid or Thermal relief for zone connection option.

Edit: either pad Properties, or footprint Properties with pad Properties inheriting the footprint.

Press the B key to fill/refill. Press the 8th Icon on the left to make sure the filled zone is visible. As a quick check see if it shows up in the 3D viewer or gerber output.

I’ve verified the connection types for several of the pads are “Solid”. I’ve also tried toggling the pour to several other nets (all have pads or holes in the connection area). No change.

I’ve tried redoing the fill (using the B key and dropdown menu) every step of the way.

I tried doing the fill and then viewing the 3D Viewer view of it. I does not show the pour, but it does show an error box. “Unsupported DRAWSEGMENT type Polygon, Cannot determine the board outline”. I’m betting this is somehow related, but I don’t see any other info and the 3D view looks exactly how I would expect with the board, pads, traces all showing up as it does in Pcbnew.

What’s the best next step for troubleshooting? Googling didn’t seem to bring up anything relavent, just a few listings for people compiling or building kicad code. Delete footprints one at a time to see which one is causing it?

How does it look like if you turn Edge.Cuts visibility on?

Could you show a screenshot of the zone settings and of the pad properties of the GND pad (assuming you have selected the GND net)

How does it look like if you turn Edge.Cuts visibility on?

The same. I’ve tried toggling different layers and it appears that visibility in Pcbnew has no effect on visibility in the 3D viewer. I get the same polygon layer error every time though.

Could you show a screenshot of the zone settings and of the pad properties of the GND pad (assuming you have selected the GND net)

Pad properties - One pad on GND net.

OK. This is strange. I just tried a pour on a project I’m starting. It briefly showed filled as I completed the outline but then blanked and didn’t display. I went to the ‘show outlines of filled areas’ (second below show filled) and I saw the outlines. When I went back to the filled Icon they filled.

Now that it has started working it seems OK on subsequent attempts.

Nope. These are the footprints properties. The pad properties are sometimes hard to reach :wink:

Ok, I think I’ve got it whipped. I just read a different tutorial that suggest creating the board outline using the “Add Graphic Lines” tool instead of the polygon tool. A quick check shows that it is working. Let me just check that I’m right and I’ll report back.

Oh geez, I don’t know why this seemed to be so difficult. If anyone has insights into why a polygon created on the edge cut layer does anything differently than a line on the same layer, I’d be interested to hear your thoughts.

The pour is working just as expected. Can do the visibility and everything.

Thanks for the patience everyone, this was frustrating. Seems I can finally ditch eagle. Yay!

I doubt using the polygon tool is a good idea for creating the edge cuts layer. That one would fill the full area i am really not sure if kicad can deal with that.