Connector problem

Hello everyone !

I’m having trouble with 2 of my connectors. The footprint I assigned to them is the same ( as in through hole ) as the others. But on my 3d view it does not give me the holes of them.

How is that so and how do I fix this ?

And how do i remove the blockage of the ground pins for the main connectors ? I know it does this because it is automatticly connecting to GND. But the connectors don’t fit if the holes are blocked up.

The 3D view is simply a model, it is not intended to represent what the real board will look like. Nonetheless, a search of this forum would have found a recent thread about this issue and how to resolve it.

1 Like

If I put the 2 conectors that have no holes in the darker purple zone it generates the holes for them and if I put them in the PCB outline it fills them up.

Alright thanks @1.21Gigawatts that’s handy to know.

It’s fixed ! that was crazy fast.

To elaborate a little more … it is intended to be a mechanical model and, depending on the quality of the component models, should provide a relatively accurate mechanical representation of the finished board. However, how the “real” board is fabricated is determined by the Gerber files and not the 3D viewer.


yeah @1.21Gigawatts I had figured that out. I use the 3d model mainly as a “how does it look now” option. :smile: And was just figuring out how my problem occured.

It’s caused when copper zones overlap holes. An optimization to improve rendering speed on some older computers does not remove the copper from zones where they overlap holes unless the option is enabled. In the soon to be release KiCad V5 this is no longer an option, the copper is always removed from holes.


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.