Bug: pcbnew, 3dview, 'copper fill' hides mechanical holes for PTH

I have designed a small board containing an interface circuit and a simple switching power supply. Due to the presence of the latter, I had to add some copper fills, some of them including several PTH component pin holes in their interior. Then, when I had a look at the 3D view of the board, I noticed that the copper layer seems to have covered the included holes:

Nevertheless, I checked the technology files and everything seems fine: only the solder mask extended over the pin holes. In sum my question is: is the 3D view of the layer buggy or am I doing something wrong?

when you remove the copper fill, does it the solder mask extend over pin holes?
If possible can you show as the image when there is no copper fill.

Looks like a graphic artefact, where the mechanical holes are created before the copper fill is being created in the 3D engine.
If the PCBnew editor window shows it correctly and more importantly the gerber viewer(s) show that the gerbers are correct you have nothing to worry.
If you want it logged with the developers, this is the place to report bugs:

PS: the gerber files will have copper over all mechanical holes that are plated, that’s how the CAM software actually knows which holes are PTH and which are NPTH (non plated through holes).

1 Like

It is a graphical artifact of the 3D viewer, and an indication that the OP didn’t enable thermals on those pads. If thermals were enabled there would be individual spokes radiating over the drill hole from the center (where the pin is) to the filled plane. It seems that the 3D viewer doesn’t “drill” out plane connections to the center of the holes.

I haven’t been bothered by it enough to submit a bug report. And, it isn’t critical (IMHO) enough to be fixed for v5.

Could you provide me a pcbnew file that shows the issue?

I remind that if you have a zone fill, it has to be “filled” (processed) in pcbnew (press B) to be displayed correct in 3DViewer. Also, the options “Remove holes” in 3DViewer must be enabled.

1 Like

Here it is:

Sorry for the later, but I had a very busy day.

As mentioned above if the issue is only in 3D view then it should not be a big problem for your design, and I think its an issue worth reporting.

1 Like

I couldn’t find that option in the nightly I got installed?
I was trying to find it earlier and would have mentioned it, but it’s not there for me :neutral_face:

Version: (5.0.0-rc2-dev-655-ge0ca5bab1), release build
    wxWidgets 3.0.3
    libcurl/7.54.1 OpenSSL/1.0.2l zlib/1.2.11 libssh2/1.8.0 nghttp2/1.23.1 librtmp/2.3
Platform: Windows 7 (build 7601, Service Pack 1), 64-bit edition, 64 bit, Little endian, wxMSW
Build Info:
    wxWidgets: 3.0.3 (wchar_t,wx containers,compatible with 2.8)
    Boost: 1.60.0
    Curl: 7.54.1
    Compiler: GCC 7.1.0 with C++ ABI 1011

I seem to be wrong. I’m running a really recent nightly (July 1st build) and I notice that the thermal spokes don’t cover the hole. I’m not sure when that was changed, and I don’t find a setting to un-fix it. Here is an example:

What version of KiCad is the OP using, 4.x?

I apologize for forgetting to do it before: here they are

Application: kicad
Version: 4.0.7 release build
wxWidgets: Version 3.0.2 (debug,UTF-8,compiler with C++ ABI 1002,GCC 4.2.1,STL containers,compatible with 2.8)
Platform: Mac OS X (Darwin 17.6.0 x86_64), 64 bit, Little endian, wxMac
Boost version: 1.57.0
Curl version: libcurl/7.54.0 LibreSSL/2.0.20 zlib/1.2.11 nghttp2/1.24.0

Attached please find a copy of the PCBNew file: however I just tried the “Remove holes” option in the 3D viewer and it works perfectly.2018-07-02_Arduino_UART_file.kicad_pcb (71.7 KB)

And here it is the picture:

1 Like

Ah, so you still got that option, good.

Just remember, this option is in the v4 to work around the visual glitch, to make the eye-candy better. It doesn’t affect gerbers or what you see in the editor canvas in PCBnew.


The option should be found in the 3D viewer:
Preferences -> Drawing options -> Show holes
I am not sure about it, since I am using the Italian
localization of KiCAD, and for me it is
Preferenze->Opzioni di disegno->Mostra i fori nelle zone

1 Like

On the V5 version I have installed: Preferences, “Render Options”, “Show holes in zones”.

This feature exists because on complex boards with lots of zones it can take a while to pre-calculate the 3D representation of the board, also it may generate heavy data for old GPUs.


1 Like

@Joan_Sparky, @kammutierspule

Preferences, “Render Options”, “Show holes in zones” in version 4.0.7
In v5-rc3 as in Joan_Sparky pictures.

1 Like

effectively I did not enabled the thermal pads nor the thermal vias for the shapes touched by the copper layers, since the board is itself quite small that I am confident that the higher heating power necessary to solder the components is more than compensated by lower track impedance so obtained.

Ok. I didn’t realize it was an intentional decision to flood fill the pads, I was concerned it was unintentional.

1 Like

Sorry my mistake, apparently it was removed 6 months ago. Now it is always enabled.


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.