Connect a Polygon to a net ->DRC

I need to make some tracks on my PCB a bit wider to support more cooling and allowing for higher currents. I can somehow paint areas with polygon and circles on Dwgs.User and move them to the copper plane afterwards.

So far so good.

But the DRC check will tell me there is something interfering with my net.

So I thought, if I just could assign that polygon area to the actual net I work on, than I could avoid the errors and also the DRC will check for min distances etc.

Or is there maybe a way to peek and poke already drawn tracks, into wider areas?

Or am I completely on the wrong track here?


I don’t see a way to assign a net to a polygon. Maybe I’m wrong.

It is possible to change the width of the track to a wider one.

For polygon like shapes, use a copper filled zone. It can (should) be assigned to a net, a specific clearance can be set, etc.

I just found a workaround…it is possible to draw copper tracks over existing coppertracks. With super big or supersmal tracks I can somehow model a bit- and the tracks are assigned to the nett and keeping DRC happy :slight_smile:

This is a very bad idea in KiCad:

If you start this way, then you learn yourself bad habits that get you into trouble later.
For example, the Interactive Router in Pcbnew is a powerful and wonderful tool, but it does shove copper tracks around, and it easily damages your “artwork”. You can disable that function, but the you also loose it’s benefits, and those grossly outweigh it’s limitations. It is much better (in the long run) to learn to use the Interactive Router effectively, and to do that you have to properly set up your design rules. You can find these in: Pcbnew / File / Board Setup / Design Rules

If you use these properly, then you can for example set a track with for a net class, and then by a right click on a track belonging to that net class change the with of existing copper tracks to that width. Such a “Net Class” also has settings for the clearance (Distance between copper and other items) and settings for via’s to use.

The “Polygon” is a graphical entity. It is possible to put such a graphical entity on a copper layer, but that is not it’s intended use. The way you should do it is to use a “copper zone” as eelik already suggested. A copper zone is assigned to a net and it has a lot of smart features build in. For example, it automatically (after manual re-calculate with B shorcut key) calculates clearances form other copper tracks in the area, and it can generate thermal vias for the pads that are inside the zone.

Another possibility is to design a custom footprint, and then embed a small copper area as heatsink into the footprint itself. To give better advice, tell us more about your project. Maybe a screenshot helps…

I use the Net classes already because I need diffrent isolation distances and track width.
But …autorouting? No! I route every track by hand, usually with ee schema on the other screen. I have too much going on in that circuit to trust any autorouting, and that is besides heat/current issues also soldering and manufacturing issues.
And I also love the work of routing.

Copper zone- I will try that one - it did not work spontaneously but I will give it another shot.

Now that I already have you here, another question: IS there a split pane option in KiCad? I have a 4 Layer design and just tried using the two power panes also for some additional tracks . but I can only use one of these panes, not both- which is somewhat weird.

What I want ist to make the same net in 3 diffrent panes (maximum current issues).

No need to be alarmed.
There is no auto router in KiCad.
The Interactive router is not an auto router. You still make all connections manually.
What it does do is shove tracks and via’s aside to make room for just that extra connection you want to squeeze in. This is a real benefit, especially on dense boards.
The “Interactive Router” is also not a special option. It is the default (and currently only option) in KiCad.

If you have any problems with: Pcnbew / Place / Zone then post here…

I do not understand what you mean with:

What is a split pane?

When designing multi layer PCB’s you always have to keep in mind the manufacturability of the PCB.
To keep it simple: Use simple via’s that go through the whole PCB. “Blind” and “Buried” vias are expensive options for complicated designs. “Back drilling” is currently not supported in KiCad (but there is an issue for it on gitlab).

Making a 4 layer PCB without zones would be folly.

KiCad usually works with layer pairs, and you can switch between them with [PgUp] and [PgDn] There is an option hidden in plain sight to set on which layers that works:

I have only designed 2-layer PCB’s so I do not have much experience with it.

Yes, there is…

You can set the Track width before drawing it and/or after drawing it.
If after, set the desired Width, then double–click the track.

Ensure the Pref’s are set (see screenshot)

Not really because (no matter what the board layout editor says) KiCad has no way of using a copper layer as a plain. Layer type pull-down in the layout section of the board settings window are really only for communication with external autorouters through Specctra export. See the pop-up help text in this screenshot:

I only set those for personal documentation reasons. I haven’t generated a gerber job file (recent feature) in a while so I don’t know if what is selected in those drop-downs will also be reported there.

In KiCad to create a plane, you have to draw a filled zone (known in other software as a copper zone, copper pour, flood fill, etc). You can draw as many as you need or as many as will fit in your board, whichever comes first. :wink: If you have overlapping zones, you can use their priority setting to force one to fill instead of another in the overlap area. Zones are not automatically filled/recalculated. Press ‘B’ to force all zones to fill for the first time or recalculate after changes. If you want a full board zone (what is typically known as a plane) you can either draw it with your desired edge standoff, or you can draw the zone outline larger than your board and only the portions of that zone within the board outline (as defined on the Edge.Cut layer) will be filled with copper.

One bit of caution, if there are islands in the board they won’t be filled unless a pin/pad of the same net is within that island. If there is a pin/pad of the same net within the island it will be filled, but still floating. This is unlike OrCad (from the '90s, not sure if it has changed) where you could define an origin of the flood fill and isolated pins wouldn’t create an isolated island making it easier to spot those floating pins.

?? Not what I thought a split plane was… Do you mean 3 planes, each on their own layer? I don’t think you can define a zone to more than one layer. You would have to draw the zone on each layer (or draw it once, copy and paste it twice, and change the layer for the two copies).

Thanks for all the good answers and tips!

Well- when I draw a copper zone it is empty, when I press B nothing happens.

Split panes- when I define a layer as GND layer some programs do not allow me to route signals through that layer- but now I learned it does not matter how I call the layers in KiCad.

Vias thru the whole board? I dont think I will do that. I have mixed assembly- with thc and smd- and I am not shure I want all the holes fill up when soldering the thc- or do I? What is your best practice there?
I also habe some vias under bigger smd pads.

The routing problem:

I have a relay (thc) and a connector (thc), 4 layer board. I cant make 10mm wide tracks, but I can male 3 times 3mm (4th layer is top and smd layer).
I also can widen the tracks to get some sort of heatsinking at least. So it will be less risky running the pcb in higher temperatures.

I can draw a track on the backside, check. I can draw on middle layer 1, check. As soon as I draw on the third layer, the track on the second layer disappears. No matter in wich order I do that. It does not allow me to draw on more than two layers.

Am I missing something?

using v 5.1.9, no problems drawing 10mm wide track on four layers…

Two potential issues: (Yeah, they might be obvious, but just in case they aren’t…)

  1. Did you assign a net to the zone when creating it? If not you can edit it to add the required net.
  2. Do you have a pin or pad of the zone’s net within the zone on the same layer as the zone? If you don’t have at least one pin/pad in the zone it won’t fill.

Yes- that works- with four layers- but when I actually connect- pin to pin, the moment my third track hits the pin, the second track will be deleted

Pin pad in the zone? So i need to start from a pin with the zone? Its not enough igmf it lying on a track and has this tracks net assigned?

Ha! I maybe found a hint! There is an option under geneal / pcb new/ routing to delete old traces if drawn new …

but It does not change anythinbg if I click it. I also tried to change the routing options in the interactive routing editor - NOTHING! Really strange. All the shove, walk around etc stuff does not have any effect if I activate it.

I am running on MacOS if thats maybe causing something?

I’m using a Mac.

This may help (if I understand what you want to do)…

I did this:
• Made a New Footprint
• Drew Polygon,
• Added a THT Pad (must have an Anchor (Pad or Via)). Does not need to be THT, can be solid.
• Made Pad From Shape… saved
• Placed the footprint on PCB
• Drew a 10mm track
Verified pad, polygon and Track are on same net using the Highlight tool…

I cant upload a video as new user :frowning:

If you take two of your patty cakes, and try to make connection between them, than any new connection will erase the prior one.

I just read thats a feature , but I cant turn it of. If I unchek the box under preferences nothing happens. Kicad still erases every old trace whan I drwa a new one (And basically thats what I want to do: Drwa several tracks without erasing the old ones

Seems to work for me (vid)
My pref’s shown below shows Auto Delete checked and overlaid track still works.

Note: All are connected to the same Net because I did NOT fuss with the Nets…

EDIT: Added showing a track overlaid with same pad connections - no problem

Strange, I disabled the Auto-delete but i did not do anything.

What happens if you just try to make connection on all layers between to two uppermost pads?

That is what I am trying. to have the current between two pads on all layers of the pcb.

No problem…

Note: the Footprint Pads are set to All Cu layers…

Now I got it, finally!
The option was hiden in the interactive router settings, second checkbox in the lower section, remove redundand traces (maybe wrong translated - I am on german in Kicad).

After I unchecked it I can finally route totally wild over all layers!

Sorry for the mess, I hope the thread will help some others in the future.

Thanks for your patience!