Change layers name

Hello,

I would like to change my layers name but after I change them in the layers option menu, it doesn’t save my changes

I have the following:
Layer 3 = PWR_12V
Layer 4 = PWR_3.3V
Layer 5 = PWR_1.8V

And I would like the following
Layer 3 = PWR_1.8V
Layer 4 = PWR_12V
Layer 5 = PWR_3.3V

Do you know how I could save this problem ?

Thank you

Are you sure you want a full layer for every voltage? Such high layer counts can be quite expensive.
Especially as i miss the layer for ground in your list (so you would need at least 6 Layers for your list to make any sense: the 3 positive supplies plus a ground on the inside and the two outer layers for pads and signal traces.) In a multi layer board the first potential that should get a full layer is ground. Doing so removes the need to think about current return paths in high detail.


I personally mostly work in 4 layer setups. Top and bottom layer for signal routing. One of the inner layers holds an uninterrupted ground plane and the other layer is for positive voltage supplies.

I would really only go to higher layer counts if i no longer have enough room for signal traces as i then also need an inner layer for signals. Which is mostly the case when working with high pin count BGAs. (But even there i would still only have one postive supply layer. But possibly more than one ground layer depending on if there are things that need guarding or shielding)


Also note that changing the layer name does not really do anything for kicad. If you want a power plane (a filled copper area) then you need to add a copper zone. See How to create a power plane (using zones)


But now to answer your explicit question: Yes layer names can be change in File -> board setup -> Layers
Be aware that your manufacturer might need extra information to parse the correct layer stackup if you deviate from default names.

Hello,

Thanks for your reply !

I have more than those layers on my design, I just want to change the name of those 3
I have some mechanical constraints which me obligated to have several power plan on my design

I go to Options -> Layer option, I then change the name of my layers and press ok. All of my layers are regenerated but the change of names hasn’t been saved

Which Kicad version are you using?
I have just tested it works fine on v5.1.5. I have changed several times the names of the copper layers successfully.

I am using Kicad 5.0.1

I will update it and check if it works

KiCad 5.0 is no longer maintained so you might want to update to 5.1 (Fully compatible but quite a bit of changes to the user interface)