Can't find an upgrade route to 6.xx

I have tried to upgrade from V5.99 to 6.00 several times, just yesterday was the most recent, and it acts as though it’s installed, but KiCad version # doesn’t change…

Application: KiCad
Version: 5.99.0-unknown-ac933d4e83~109~ubuntu20.04.1, release build
wxWidgets 3.0.5
libcurl/7.74.0 OpenSSL/1.1.1l zlib/1.2.11 brotli/1.0.9 libidn2/2.3.1 libpsl/0.21.0 (+libidn2/2.3.0) libssh/0.9.6/openssl/zlib nghttp2/1.43.0 librtmp/2.3
Platform: Linux 5.13.0-27-generic x86_64, 64 bit, Little endian, wxGTK, mate, x11
Build Info:
Date: Aug 4 2021 18:53:57
wxWidgets: 3.0.4 (wchar_t,wx containers,compatible with 2.8) GTK+ 3.24
Boost: 1.71.0
OCC: 7.3.0
Curl: 7.68.0
ngspice: 31
Compiler: GCC 9.3.0 with C++ ABI 1013
Build settings:

When I go to term and do this:

sudo add-apt-repository --yes ppa:kicad/kicad-6.0-releases
sudo apt update
sudo apt install --install-recommends kicad

It behaves as though it’s all installed, but KiCad Ver. number stays at 5.99.

Should I remove KiCad first? How would that impact my existing schematics?

Thanks for any advice…
(I want to upgrade because of the many small glitches in 5.99. I’m hoping 6.xx fixed them).

---------------------------Requested info------------------------------
grep kicad /etc/apt/sources.list.d/*
/etc/apt/sources.list.d/js-reynaud-ubuntu-ppa-kicad-focal.list:# deb hirsute main # disabled on upgrade to hirsute
/etc/apt/sources.list.d/js-reynaud-ubuntu-ppa-kicad-focal.list:# deb-src focal main
/etc/apt/sources.list.d/js-reynaud-ubuntu-ppa-kicad-focal.list.distUpgrade:# deb hirsute main # disabled on upgrade to hirsute
/etc/apt/sources.list.d/js-reynaud-ubuntu-ppa-kicad-focal.list.distUpgrade:# deb-src focal main
/etc/apt/sources.list.d/ focal main
/etc/apt/sources.list.d/ deb-src focal main
/etc/apt/sources.list.d/kicad-ubuntu-kicad-6_0-releases-impish.list:deb Index of /kicad/kicad-6.0-releases/ubuntu impish main
/etc/apt/sources.list.d/kicad-ubuntu-kicad-6_0-releases-impish.list:# deb-src Index of /kicad/kicad-6.0-releases/ubuntu impish main

----------------------------Requested Info---------------------------

sudo apt-get upgrade

Seems like way too much to post…are you sure you want this? I did both Update and Upgrade yesterday, today there are 55 upgrades…I ran it and saw no error messages. No error messages yesterday either.

--------------------------Requested Info----------------------------

sudo apt-cache show kicad | grep Version
Version: 202108041853+ac933d4e83~109~ubuntu20.04.1
Version: 6.0.1-1-202201152026+79c1e3a40b~116~ubuntu21.10.1
Version: 5.99.0+really5.1.10+dfsg1-1

Removing KiCad won’t affect your schematics. I’ve uninstalled and installed many times on Fedora. It should work the same on Ubuntu. But be aware that when you upgrade and open and save a schematic, the schematic will be upgraded to be compatible with the new version. So downgrading isn’t really recommended. You can always take a backup copy of your schematics before you upgrade. (This should be your daily routine anyway).

apt update

only updates the repositories. It does not update any program.
Read some more about this by typing “man apt”, and a slash (to enter a serch funcion) and type the search string (which is “update” (without the quotes) in this case)

       update (apt-get(8))
          update is used to download package information from all configured
           sources. Other commands operate on this data to e.g. perform
           package upgrades or search in and display details about all
           packages available for installation.

To update your programs, you have to follow with an “sudo apt upgrade”)

       upgrade (apt-get(8))
           upgrade is used to install available upgrades of all packages
           currently installed on the system from the sources configured via
           sources.list(5). New packages will be installed if required to
           satisfy dependencies, but existing packages will never be removed.
           If an upgrade for a package requires the removal of an installed
           package the upgrade for this package isn't performed.

No, that should not be necessary

No, KiCad does not touch your schematics during an (un) install.
I also advise you to think about and implement some decent backup strategy for all your personal work.
something as simple as copying all your personal data to an external HDD or an USB stick every now and then suffices to guard against the worst hardware crashes (which do happen every now and then).

A more evolved backup strategy would involve a NAS and some automated stcripting.

Even a half decent backup strategy gives a lot of ease of mind for a guy like me. I get nervous if I have not made a backup for some months. Apparently there are also people who do not even think about backkups until they discover their data is gone.

Strange that it is not upgrading.

Can you post the output of
grep kicad /etc/apt/sources.list.d/*


sudo apt-get upgrade


sudo apt-cache show kicad | grep Version

Isn’t it possible that if you uppgrade to a wrong version, you can’t go back. Some versions change work files, if you open and save them.

Yes, but only for nightly (x.99) versions. Stable versions do not change the file format. OP is trying to update to a stable 6.0.x version.

@gmc: Added the info to original post…

These two lines look wrong. What should follow the deb is the URL of the repo, not the words Index of. I don’t know how it got that way.

Please do a:

sudo apt list --upgradable

Not relevant, but the use and confusion between update and upgrade is historical. Update refreshes the metadata, and upgrade does the actual install of new versions. And then there is dist-upgrade which is used once in a blue moon. Other packaging systems use for example refresh instead of update.


sudo apt list --upgradable
[sudo] password for jim_hitek:
Listing… Done

In other words, there’s nothing that needs to be upgraded. I think.

That deb line is wrong. Can you delete the .list file it appears in and fetch the repo spec again with apt-add-repository? I’m assuming a glitch on the part of the maintainer. I’m on a mobile so difficult to give you the exact commands.

@retiredfeline: No idea what you mean. I didn’t do anything with any .deb I just entered the install instructions as shown in my first post. And as I said, I’ve tried doing the install several times over the last few weeks that ver 6 has been out.

I see where you said above that the .deb line was wrong, but how would I have anything to do with that? That would be the install routine I guess.

‘fetch the repo spec again’? Could you explain, or show an example? Note that whenever I’ve tried to install 6, I’ve just searched google for instructions and then tried them.

No need to hurry tonight, I’m done until the morning. Thanks for your help.

I believe his command lines are correct. The “Index of …” text is the forum software being “clever”

Ok, I think I see what’s happening. The version you have is:


As you can see from the version info. Unfortunately 2021… ranks higher than 5. or 6. so cannot be upgraded. I would just remove 5.99 and then install kicad. Also all the associated packages, like the kicad libraries.

Thanks @thebigg.

@retiredfeline: Nope, I have this version…

lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 21.10
Release: 21.10
Codename: impish

Version of kicad as shown in your first post, not your Ubuntu version.

Application: KiCad
Version: 5.99.0-unknown-ac933d4e83~109~ubuntu20.04.1, release build

That package was installed while you were running 20.04. Incidentally it’s a good idea to cull all repository lines that are for previous versions of the distro, i.e. not impish. But I think you are ok, because the focal repo isn’t active as the file has been renamed

After adding the the repository and sudo apt-get update && sudo apt-get upgrade you should see that the actual kicad package was held back.
You have to manually upgrade it with sudo apt-get uprgade kicad

1 Like

Didn’t work:

sudo apt-get upgrade kicad
Reading package lists… Done
Building dependency tree… Done
Reading state information… Done
kicad is already the newest version (202108041853+ac933d4e83~109~ubuntu20.04.1).
Calculating upgrade… Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

I think I’m going to try the uninstall-reinstall thing and see what happens.
I’ll be back.

I’d uninstall everything, then go though all the files under
and remove the ones for kicad. Then re-add as per the download instructions and re-install.

There is something that’s gone very wrong as you have a version 2021* which is higher the 6.* so it will never upgrade.

You could force a ‘upgrade’ or even download all the .deb files and install manually but it’s going to be far easier just to remove/cleanup/install.

An “uninstall / re-install” is unlikely to work well. The most likely outcome is that you tell your computer to install the same version again.

What may have more success:

  • Un-install KiCad.
  • Remove all those old repostitories from /etc/apt/sources.list.d/
  • Add only the repository for the current stable version of your OS.
  • Install KiCad.

And what operating system are you running?
do you know if KiCad V6 has been packaged for your current operating, or are you using instructions from a similar distribution in the hope it will work?

This is the only mention of KiCad in /sources.list.d


OS is Linux/Ubuntu 21.10.1

Any and all KiCad software I installed myself after searching the web for instructions and following those that made the most sense using TERM. Googling, “How to upgrade KiCad Ver X.XX to Ver X.XX”.

But then when it changed to Version 6.00…there weren’t many entries, which seemed strange, but I followed what I could find. Reason I wanted to try it was there were so many glowing reports of how good it was.

And that’s where I am now, with a V5.99 even though I’ve tried to install 6.0 multiple times over the last month.

I have just today found this, I don’t recall ever seeing it before. It looks very concise and I’m going to follow it…see what happens: Install on Ubuntu, Ver 6

Never mind. That link has instructions for Software Manager…the 21.10 version did away with that, I have SNAP now. Checking to see if they work anyway.

Nope, no path I could find to do it that way. Also checked using the app Synaptic Package Manager and did an upgrade to KiCad using that app. No change.

Did a full uninstall, now doing a reinstall, following the TERM installation instructions in that link I show. I should mention that I checked and yes, it was fully uninstalled. /sources.list.d was gone too.