Cannot Find Foot Print (SOLVED)

I am a newbe and I am sure this question has been asked dozens of time but I cannot find it. I created a beautiful 25pin 1mm pitch SMD footprint for a ribbon header. I saved it in a .pretty folder located in the same folder as my project. Now, I am in the CvPcb trying to match my new footprint to a component in my schematic I created earlier. I cannot direct the program to it.

Did you add the pretty directory to your local fp-lib-table? (Try set the lib as active in the footprint editor. If it does not exist in this list it is not yet in the table.)

If you did not yet add it, open the footprint library wizard found within footprint editor -> preferences menu.
Select files on my computer and press next.
Navigate to your lib location and select the pretty folder. press next until you get the question if you want to add it to the global table or to the project (or local) table. (I would suggest to add it to the project/local table. Just because you say you have added the pretty folder to your project directory.)

If the lib is already in your fp-lib-table:
CvPcb has filter settings. These help you do reduce the number of footprints that are shown for a specific symbol.
You can filter by footprint filter settings of the symbol (I think this might be called by keyword.)
By pin number or by library. (For the later the lib is selected in the leftmost column.)
I would guess you want the library filter activated, the keyword filter deactivated and the pin number filter activated. (The later only if your symbol has the correct number of pins.) You also need to select your lib in the leftmost column for this to work.


Thank you very much. This software looks powerful. I need to make more PCB designs to learn and keep this fresh.

1 Like


thank you very much!