Bom csv output is wrong


Kicad is still outputing the bom to a csv format with semicolons as the seperator.

how do i change it to output a comma as a separator to the csv?
It is a COMMA seperated vector format.

I won’t read the FAQ as I do it my way… which, is simple - two options:

  1. Just open the CSV in LibreOffice’s Calc (the spreadsheet app), select items shown below

  2. Edit a BOM creation file that comes packaged with Kicad - there are several with different output flavors. Below shows Results of using my tweaked (stock) “bom2csv.xsl” (It’s been a couple of years so, don’t remember if the stock/default “bom2csv.xsl” will get you what you want or if my tweak took care of that…) But, it’s worth your checking into it…

Opening CSV in Libre

Results of my tweked “bom2csv.xsl” as opened in a plain text editor (not a spreasheet). No semicolons…
Screen Shot 2023-01-31 at 13.41.17

How about we make it work correctly instead of funky work arounds? Csv files have been around way before kicad


How about your trying out the “bom2csv.xsl” and seeing if it works without needing any editing.
Also, if you’re using a CSV, they are designed to open in Spreadsheets but, it’s customary for User to select the Delimeter aspect in the Open/Import panel…

1 Like

Things calling themselves CSV with alternate delimiters have been around long before KiCad, too :slight_smile: It’s not really a standardized format, and as BlackCoffee states every tool I’ve ever used to work with a CSV lets you specify what delimiter(s) to accept.

That said all of the built-in BOM scripts that I use on a regular basis use commas, so you may want to mention which script it is that’s bothering you…

Comma seperated vector. No its not normal to select the delimiter. Especially if you use excel which started the formats popularity.

1 Like

Why do i need a script? The program itself exports the bom in csv format.

1 Like

Please explain exactly how you’re generating a BOM, I don’t want to guess. The recommended path is to use the schematic editor’s Tools → Export BOM dialog which gives you a choice of export scripts for different formats and options, including custom ones.

“Value” if we’re being pedantic :slight_smile: I can assure you that excel gives you a choice of delimiter options.

1 Like

I don’t think there is something incorrect. It is the most safe way to be able to include fields with commas in them and also support values with different locale settings. Not everyone use the same separator for example. And KiCad cannot make everyone happy. You can however edit mentioned scripts the way you want and move further.

Does it really? I think it is only calling some Python scripts to do the export…

I think OP is using the PCB editor’s limited BOM export functionality, but like I said I don’t want to guess.

1 Like

Ah, indeed. I missed this… :slight_smile:

Nah, it goes back to Fortran and in spreadsheets back to Supercalc. Microsoft didn’t invent the Internet either.

As others have written you just need to use the appropriate conversion script. KiCad actually generates XML so you can’t lay responsibility for that at its feet.

As saidp popularity, not creation. And yes i am using the export option of the program. As i said.

Ive never dealt with fortran but thats a programming language. Not a program.

I still think if ut saves as a csv file it should be in the right format but id be happy if you showed me how to import to excel with a custom separator. It has never asked me for one and there was no option when i tried a manual open.

Kicad export option did not make an xml file. It made a semi colon seperated value file which it saved under the extension of csv. Which is wrong. This is what needs to be corrected.

It’s all controlled by the conversion script. Be good and show people the command you are using and the steps you took so they can help you help yourself.


on selecting it. there is no conversion script. there is just a save as bill of materials

i am guessing many of you are elite users that are doing things the same way from who knows how long ago but i am new and am using what is provided. what is provided is saving the bom as a comma separated value file and it does not.

i really didn’t think this was a hard concept to understand.

1 Like

And it is very universal. I think semi colon does not interfere with any number representation.
I don’t know what whoever came up with to separate fields that can contain decimals with a comma was taking, but he should take half :slight_smile:
I believe not only we use a comma to separate the integer part from the fractional part.

What version of kicad is that?

waiting with baited breath for 7. to drop