Backspace,left,right keys not working

Hi group

I just installed KiCad 4.0.7-e2-6376-58-ubuntu.16.04.1,release build but seem to be having problems with the “backspace,left and right” keys.

I found the following website that suggested a solution but does not work for me.


Is it possible that your nightly build switched to opengl as the default canvas but you are used to the legacy/default canvas?
(opengl has differing behavior then legacy for this shortcuts.)
Switching canvases is done in the view menu. (or using F9 for legacy and F11 for open gl)

Hi Rene,
Thanks for quick response.
I am not using a nightly build version. I installed using the following command

sudo apt-get install kicad

I also just discovered that if I start kicad from terminal with “sudo” then the keys work as expected but I don’t think this is a sensible workaround.

Can you cut and paste from your “Help > About” screen? It will show the version numbers.

Ok i have been confused by

in your version number. (Don’t ask why i did not see the 4.0.7 part)

1 Like

Hi Greg,
Please find uploaded as requested.

1 Like

Just a note for future reference. At the bottom of the window is an option to copy this information to your clipboard. No need to do a screen shot. :wink:
Application: kicad
Version: (2017-10-03 revision 3d1569081)-master, release build
wxWidgets 3.0.2
libcurl/7.52.1 OpenSSL/1.0.2l zlib/1.2.8 libidn2/0.16 libpsl/0.17.0 (+libidn2/0.16) libssh2/1.7.0 nghttp2/1.18.1 librtmp/2.3
Platform: Linux 4.9.0-4-amd64 x86_64, 64 bit, Little endian, wxGTK
Build Info:
wxWidgets: 3.0.2 (wchar_t,wx containers,compatible with 2.8) GTK+ 2.24
Boost: 1.62.0
Curl: 7.52.1
Compiler: GCC 6.3.0 with C++ ABI 1010

Build settings:

I requested the screen shot because I couldn’t find the button. In 4.0.7, it is now a menu item. The first menu item under “Help…” is “Copy Version Information”.

Hi Ola_Oni-

Which application (or multiple) is this not working for? e.g. Eeschema, pcbnew, etc?

Also, are the keys not working for anything? Or just for a specific action? If it is a specific action, can you say what you are trying to do?

Hi Seth_h,

I am using Eeshema, But I can say that this bug seems to affect any text entry controls. For example using “Place a component” I can start typing which works but should I want to delete words already typed using the backspace or the other keys I mentioned this is when I experience this issue.

I am trying learn kicad for creating schematic diagram and ultimately for pcb.

Just to re-iterate this issue is not seen when I start Kicad as a superuser with “sudo” from a terminal.

Hi All,

Any further suggestion on this reported issue. At present I am having to launch kicad from command line with “sudo” which is not the best practise.

Thanks in advance.


Which of the solutions did you implement?

Removing ibus from your system, disabling it or installing ibus-gtk + ibus-gtk3?

1 Like

I’m an Ubuntu Noob.

But, I have a few friends that are not. I believe that there is a way to set-up permissions for individual applications in a certain file/something/whatever (in technical terms).

I’ll send out a couple of emails and wait for a reply.

I just figured that if you were at least aware of this feature, you may have the knowledge to know what search terms to look for.

Hi Joan_Sparky,

Problem solved. What I must have tried previously was installing only the ibus-gtk but NOT the Ibus-gtk3.
Installing both seems to solve the problem.

Procedure taken:

sudo apt-get install ibus-gtk ibus-gtk3

Logged out and logged back in.

Once again thanks



Thanks Sprig.

Problem solved


I also had the same problem on my ubuntuMATE 17.10
running these commands in terminal worked for me
sudo apt-get upgrade libsystemd0
sudo apt-get upgrade libudev1
sudo apt update
sudo apt upgrade
init 6
Hope it works for you

You should never need to run KiCad as root.
Ubuntu 17.10 has many permission issues, which is worrying as 18.04 next month is the next LTS

I’ve been suffering from this issue making Kicad utterly unusuable on my primary PC for two years, with a laptop computer sitting next to my desktop to run Kicad. Turns out installing ibus-gtk and ibus-gtk3 solve the problem. Weird. I cannot repeat this problem with Kicad on any other computer (including a laptop with ibus and not ibus-gtk/ibus-gtk3 installed) but I’m glad to have found a solution. For all this time, searching for “can only type in kicad input box, not delete, unless highlighting and replacing characters” got me nowhere. Kudos.

1 Like