Arch linux problem with wxpython 3.0.2.0-7, reverting to 3.0.2.0-6 works fine (KiCad nightly)


#1

Hello,

after installing package updates as usual, KiCad got completely unusable. Didn’t render UI Buttons in Cvpcb and PCB Layout and eventually completely crashed.

By looking into my update history I could resolve this issue by reverting wxpython to 3.0.2.0-6.

Tried the following nightly builds:

kicad-git-r9079.bf44d394c
kicad-git-r9260.c95c77c51
kicad-git-r9338.c758e72c1

Do someone know if this issue is already taken care of?


#2

I assume you already know this, but the right place to report is the bugtracker not the user forum:


#3

https://bugs.launchpad.net/kicad/+bug/1746753

I reported a bug here, please help with adding info about findings or preferably even patches for this.


#4

This is an Arch Linux issue, they changed the wxpython package from gtk2 to gtk3. Install wxpython-gtk2 from AUR instead.


#6

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.