Applying a solder mask to the board


#1

Hello,
Tell me, what option in the program is responsible for applying a solder mask to the board?


#2

The soldermask is a negative of the resulting film. This means anything you draw on it will represent holes in the solder mask. (typically pads have soldermask enabled -> means there will be a hole in the mask with the same size as the pad.)


#3

Soldermask is considered to be already applied to the entire board; as such there is no “tool” (or option) to add soldermask.

As @Rene_Poschl mentioned, the soldermask layer representation in KiCad is a “negative”; it shows where the soldermask will be not be applied.


#4

I uploaded them a new archive, respectively, did not draw / did not adjust the solder mask, but only included it in the F.Mask and B.Mask layers in the gerber file and what they told me …:
“I checked your new file that you just sent me, please check the attached picture in the file, without 1 layer of solder mask, please add it.”!
What they want…!? If I add (put) it, then this will also be the same as with the last time “open tracks” ((no?


#5

Looking at the list of files in their screenshot, it appears they are missing the B.Mask layer file. Double check what you submitted that you didn’t forget the B.Mask layer. (Your front and back masks will be different because of the use of SMT parts.) If you are 100% sure (and can verify) that you did send the B.Mask layer file, you may want to ask them why they are loosing files…

But, more likely an accidental oversight when zipping the files to send.

Now, if you want all the copper on the bottom side to be exposed so it gets an extra layer of solder during a reflow operation (or manually if hand-soldered), you should explain that to your vendor. (Sometimes board designers will intentionally leave power traces uncovered by soldermask to allow solder to build up the thickness of the trace to increase the current carrying capacity.)


#6

Could also be that the b.mask file is empty as all smd pads are on the front layer. Maybe the fabs software can not deal with that.


#7

Yes, I already tried to add with the file without it … as indicated that there are no mounting elements on the second layer.
I will ask them about it …


#8

Yes, B.Mask is essentially empty, there are no mounting elements for soldering
It is just necessary for them to put a solder mask with fullness on the whole layer, but they cannot create one … because they lack something …! ((


#9

Somehow they wrote to me … if I generated a board in the Eagle program, then there is an option, if you turn it on then the problem is solved (see photo)

The question is, is there a similar option for KiCad?


#10

You are making this more complicated than it is. Go to Plot menu and select the 7 layers

For a 2 sided board, you will always have 7 layers plus 1 or 2 drill files. Don’t worry that a mask layer is empty or not, just send it with the others. Job done!


#11

No, this method did not help (


#12

Whatever. I’ve used that method for like a hundred boards now, it works fine.


#13

Might it be that the file ending and or file name of the gerber for that particular layer just do not match what the fab house expects?


#14

No problems here, either, with about 20 - 25 boards.

Dale


#15

The board fabricators I use charge extra for Back Silkscreen, so the standard submission is 6 Gerber files (plus one or two drill files):

  • Front Copper
  • Back Copper
  • Front Mask
  • Back Mask
  • Front Silkscreen
  • Outline (“Edge.Cuts” in KiCAD)

(A few fabricators ask you to put the outline on one of the other layers, or on ALL layers, so there will be only 5 Gerber files.)

Like @SembazuruCDE said, the image in Post #4 lists only FOUR Gerber files. The board fabricator did not receive (or they lost) the Gerber file for Back Mask.

(Why was Post #4 flagged? This thread does not make sense without it.)

Dale


#16

Yes, KiCAD has the “Negative Plot” option in the “Plot” menu, but in my version of KiCAD (a nightly build from June 2017) it is NOT available for Gerber plots (only for PDF, Postscript, or SVG plots). Like @Rene_Poschl mentioned in Post #2 (and @Sprig repeated in Post #3), KiCAD produces soldermask layers with “negative” sense by default. (The filled areas on the soldermask plots show where the soldermask SHOULD NOT be applied.) I don’t know if there is a formal Standard that requires this, but it is the customary practice for all the board fabricators I have used.

If your board fabricator requires a Gerber file showing where soldermask SHOULD be applied, then KiCAD can not produce the file. Find a different board fabricator. Like @bobc said in Post #12, there are dozens of fabricators who can use the Gerber files produced by KiCAD with the options shown in Post #10.

Dale


#17

I am supported on this occasion by asking a series of questions … “why are there so many layers !?”
As a problem it did not solve with B.Mask


#18

Files in my standard, look at the photo:


#19

I once wrote for PCBWay support to read this topic a little on the forum … but she still doesn’t want to deal with it ((
“She asks for the right (for them) B.Mask …!?”

As far as I understand, the problem is that there are no mounting elements on layer 2, and therefore they need to specify a forced soldering mask, but in this case, if you use KiCad, I will cut the board’s tracks and they will be unprotected.
I’ll try another option …
add any mounting element on layer 2 without connecting to the tracks
Screenshot_6

I am waiting for more results on verification from them …


#20

In the errormessage above they write something about file ending gts not gbr.
This would mean you need to select the “use protel file ending”.
(Not sure if this is the only problem they have with your files. Might just be an out of date description.)