Append board causes crash?


I 've created a project with eschema, netlists, cvpcbs and everything. Then I create the file in pcbnew and use append board so I can connect an older board (created in the same version of Kicad). After all editing is done I save and close the window. Now I don’t have accesses to the file. I click on it as normally do and then Kicad crashes. I 've tried to make again the file and make a copy, just in case, but same thing.
I have also tried to add netlist file in the older design but I have the same problem. Pcbnew crashes.

I have designed this board at least 3 times and then the file is not accessible. What can I do or what I’m doing wrong?
(Running in virtual machine, win XP, Kicad BZR 6245)

Edit : Creating a new project with same library (from older pcb) caused error again. Creating a new project with Kicad libraries no error occurred. So something is wrong with modules from the older pcb. I’ll check it and update again.


Just in case - any error messages being thrown at you that could help for troubleshooting?

None. The window opens and then closes immediately.

What caused the problem was an edition I’ve made in a module.
As Maui suggested in this post, I changed *.Cu to In2.Cu. That, apparently, is responsible for all that mess with files that can not be opened. I thank Maui for giving me this solution but sadly I can not use it.


Hm… but you can open the files/projects each on their own - even with this modification in there, right?

Maybe you can kick out the responsible footprint before attaching the board to the other and then reintroduce it?
I know, awkward stuff and you need to keep the project of the board which has this part in there as otherwise the DRC will run bonkerz :slight_smile:

PS: I did 2 panelized designs so far and always reroute the added boards (after including the schematics in eeschema).

Yes, I can open the project, schematic, cvpcb and footprint editor but I can’t open Pcbnew.

I’ll try it and let you know.

Sorry for my late reply but I had a deadline.

Indeed Joan_Sparky removing the responsible footprint and adding the fixed one solved the problem.

Thank you for your help.