Absolute newbie forum? <=== "not connected"

Elect Eng, never tried Kicad before.
Could not see a forum topic/forum for absolute starters.

Great job, but missing something so obvious, it seems you don;t bother to say ot for new people. Seeking a link to that.

The choice of the collection of tools seem intuitive enough, but all explanations I’ve seen seem writen for those who already know the jargon and workings.

Saw an example source, (maybe sparkfun getting started) two resistors, two capacitors, three 0volt power points, in & out global labels. Green wires.
Skips everything needed to get started on schematic entry, skips to later stuff. More a comparison.
Created Simple enough, despite the choice of pan and zoom oin the mouse being something that I will likely swear about for a long time.
R is r, C is C, cool.
Rules checking points to annotation, which seems reasonable.
After annotation, “global label” is “not connected” pin 1 of capacitor X not connected
Attachment points for power not so obvious, but it seemed to connect it.
Matrix solution doesn’t like opens, so connections & grounds: ok.
rule check.
“Not connected”.
“Getting started” has depth, admirable depth, but low on what to do when you know lectronics and a keyboard and a mouse, but not familiar with cad systems and the jargon.
Google - some incomprehensible stuff about grid, much about custom symbols, much detailk and depth, but no simple stuff.
Deleted every component.
Placed them again. No component moves. So no excuse to be off any grid.
Zoom shows green wires seeming to end on component pins. NO obvious gaps.
“Not connected” on one ground.
Delete that gorund. Wire the cvonnection to the other ground that don’t have errors. Now they are “not connected”.
Just the obvious, please?
Something SO OBVIOUS that I found it written nowhere?
In terms of “connect” and mouse and keyboard?
Select components
Place components
Place sources, and gounds.
connect with wires.

… and ?
… being careful to …?
Much appreciation to the one who spots what’s missing. Many thanks in advance.
SO OBVIOUS, it wasn’t written?
Is there a place for collecting the "Into to KICad: before the existing “getting started”?
Admirable that the “getting started” would introduce aliases and create symbols and doing things with busses, but this seems very much “getting started with Kicad (when you know other CAD packages)”. Any place for getting started from scratch?
Many thanks.

A good video tutorial is the getting to blinky series by @ChrisGammell https://www.youtube.com/watch?v=BVhWh3AsXQs

Also if you show screenshots then we can probably help more.

1 Like

Welcome to the forum, Nanren888

This youtube video helped me learn the steps to get kicad to make the PCB for a small (3 component) circuit board. About as simple as possible to make a PCB that actually works.

0 min:0 s start
1:54 assign component footprint for each component
3:31 ERC
3:35 read current netlist
3:51 layout board, traces and vias

Yesterday, as an EE, I was inspired to consider using JLPCB to make my PCB’s by this longer video series for Kicad beginnners:

1st video by Simple Electronics, 1 - make schematic:

Kicad for beginnners, 2nd video by Simple Electronics, 2 - assign footprints
to all symbols:

Kicad for beginnners, 3rd video by Simple Electronics, 3 - lay out the board

Kicad for beginnners, 4th video by Simple Electronics, 4 - make silk-
screen pretty & helpful for population

Kicad for beginnners, 5th video by Simple Electronics, 5 - uploading gerbers to JLCPCB

That tutorial is for version 4 of kicad (I wish tutorial creators would make this very clear in their videos.)

This is what made me suspicious:

In version 5 it is suggested to use “update pcb from schematic” instead of going through the netlist (much saver and will be the more powerfull option in the future.)

I have not double checked the other videos.


I think I watched all those in preparation to trying, then trying to fix it.
I don’t want a pcb.
I just want access to spice simulation.
I naively thought this would be a quick route.
Getting to blinky - Great, but it is a series of videos. The first is intro, the second talks about re-usung the schematic of the previosu video, but none was introduced in the previous video.
So, the thought of stealing his schematic as a starter vapourised.
The others I’m sure are great in one wants to define footprints and make pcbs and define new symbols and such terribly professional things.
I wanted to just create a circuit and simulate it.
In this case, first attempt, passive RC filter.
I moved my mouse in semi-intuitive fashion, placed components straight from the library provided. R C Voltage source, seemed to snap to a grid, all very much as though it was working as intended.
global labels" reasoning that simulation might need tags of some sort & seen on examples, tutorials.
Used something green, “wire”? to connect. It appeared to snap to component connection points on grids points.
“not connected”
As above.
I did what was intuitive.
The tutorials are wildly complicated, create new component, do layout, …alias, busses, …
Two Rs, Two Cs, One voltage source, seemingly “connected”
Not connected.
Anyone see the things that is SO OBVIOUS to you users that it’s not said and I’ve missed it?
Place components and labels, connect, anotate, with wire & what else?
Repeating myself.
Thanks for the genric pointers. I’m sure once I know how to make simple connected components “connected” I’ll find those really useful, but for now, I’m just wanting to connect components and have it think they are “connnected”.
Maybe if anyone has time, they could place, from scratch, a source, resistor, capacitor and ground, label in and out & watch for the step they do that was SO OBVIOUS that no one says it?
So frustrating.
I’m going to go back 40 years to manually creating spice files soon.
When it becomes clear what’s missing, maybe we could list it somewhere in the “absolute beginner to CAD guide to KiCad”?

@holger might offer some advice on the quickest route to that goal.

Maybe you could look into other tools for entering schematics? Ngspice has a page about them.


1 Like

That was the page that led me to KiCad.
Just looking for a way to get simple stuff into spice.
Anyone know a tutorial that does not skip steps?
All the ones so far cover all manner of advanced stuff, but always skip the rudimentary steps that I just can’t get to work.
Just schematic entry, from library components?
Alternatively, anyone point me to a source of a scematic that actually works, that I can search for the missing link?
(And maybe a tutorial page on how to import it, where to put it :slight_smile: )

The reason a simpler tool might be better for you is Kicad captures a lot of other information you don’t need for simulation. E.g. you want a R but there are various types of R in the symbol library. Kicad is intended to cater for the whole process including manufacturing.

1 Like

A simpler tool?
Maybe so, but this one works, I suspect, with some simple piece to the puzzle that I am missing. Something obvious to CAD people, or at least KiCad people, but not to electronics engineers.
I’d guess you place components, connect them up & all works. Except that one thing that’s not stated. Whatever it is.
So, would love to take up the good tool. Just would love to get it working for the first example, simple circuit first :slight_smile:
I’ve seen plenty of things that are crafted to be exclusive clubs, people’s egos maintaining a steep learning curve. I didn;t read KiCad as one of those. So, I’m still guessing it is something simple, I’m missing.
When the product looks intuitive and things seem to work, there’s usually just one more unsdtated rule, learned by anyone who uses it. Immediatley becoming second nature to those and basically forgotten.
When works starts on Wed, I’ll ask some of the CAD guys, if they are back, whether the’ve tried KiCad and see if I can work out what it is that is missing.
It was worth a try asking here. Thought someone might twig to what’s missing.
Perhaps it’s a matter of maturity of the product. When it become mature there’s little drive to maintain introductory material as the emphasis goes on feature enhancement.
Anyway, If I ever sort it out, I’ll look to post something for the novices, as there seems a gap in the getting started material at the moment.
Looks like a fine product guys. Wish I knew how to make components “connected”.

I don t get you, if you would take the time you do ranting about kicad and take some screenshots of your specific problem and joust ask that Question here instead you would have an Answer in no time that gets you up and running.
Also if your after simulation, ngspice integration is more like a feature under developement as a mature part of Kicad.
At the moment i do not know how i could help you because all i can read has little to no information about your actual problem.

1 Like

@Nanren888, I agree with Detzi. When I read your first post I understood you have some problem but not what it exactly was, and I couldn’t guess it’s about simulation, not about schematics per se. You managed to do something, but not everything.

You can zip your project in the state it is and attach it here (if you have spent some time reading the forum so that you have received priviledges to do so) or upload it to a file service and link it here. Or you can take a screenshot of the situation. Then you can explain more accurately what you want to do or achieve next.

I understand that newbies want and need tutorials and examples for newbies, and am sorry if there is none. But you can get specific advice here if you give specific information and question.

BTW, there is a dedicated category for simulation: https://forum.kicad.info/c/schematic/simulation-ngspice

1 Like

Reading between the lines, and taking into account of the No. 1 FAQ, I am guessing the OP has a “Power pin not driven” ERC error.

If it is not that, I have no idea. “A picture speaks a thousand words” really is fundamental in this case.

Install LTspice (Windows).

Under linux I read that you have to use an emulator like Wine wrapped around it.

You can’t get more simpler than that really.

KiCAD first and foremost is an ECAD tool to create pcb layouts, the accompanying documentation and fabrication data. The spice integration is relatively new.

But read the licence of it first. For example if you work for a chip manufacturer other than LT (now analog) then you are not allowed to use LTspice.

1 Like

You get access to software from the future though :slight_smile:

1 Like

What about a free SPICE graphical modelling software for linux?

In eeschema, press a key to add a component, then r to specify a resistor (or c for capacitor, l for inductor, led for LED, etc.) to create a new resistor, for example.
To move the resistor, hold the mouse cursor over it and press m then move it with the mouse. To rotate the resistor, press r while holding the mouse cursor over it.
To undo what you just did Ctrl -z. Ctrl-y to redo.
To wire the resistor to another component or to an existing net, hold the mouse cursor over either end and press Shift-W (or Place…wire from the overhead menu). At this point the cursor changes from its default arrow to a pair of crosshairs. Click where you want the end to be, then click along every vertex until you get to the wire’s end on whatever and double click to end it. Then press Esc to end wiring mode.

The overhead menus also have these same functions in case you forget.

Press Esc to abort whatever you’re doing, or to change from crosshairs back to ordinary mouse cursor.
To delete any component, hold the mouse cursor over it and press Delete.

It has been more than a year since I did the SPICE tutorial demo. under the tutelage of @holger. That part started w/ installing ngspice-30 to my OS. If you use linux I can post my detailed notes that may help.

Some time and effort was put into this series as well…

Many thanks for you patience and excellent responses.
Screenshots, show the result.
I gave the steps I used so you might see what was missing.
I described the error that someone might remember what it was they learned that fixed it.
I described the steps I took after the error that did not work for me.
I attempted to give all so nothing was missing.
I pointed out that I expected the answer to be something REALLY BASIC.
I also mentioned that the tuts are great, but missing this basic thing. Difficult to describe the missing thing, as I don’t know what it is.
Images below, showing as described above.
Clearly I can place components, as mentioned above.

So, justification raving done.

And placed the same way, but no error.
Again, many thanks for the helpful responses. Hoping someone can tell me the obvious.
On a separate attempt, I set the values of everything, well, I think, everything; everything I could find. Similar error, so this time through, I have not set the values.
This time, from memory, so haven’t checked the values are sensible.

Errors, seemingly unchanged.
Something truely basic?

Again, many thanks to those who responded. Shows a great support group.

Ok, the new users can only post one image, after entering multiple to illustrate is a tad of a surrpise.
Then deleting the image post lines, does not remove them? Eek!