4 Layer with Freerouter - 1 Layer for Power


#1

Hi,

I am reading the book “Kicad Like a Pro, 2nd”. Inside the book is an example ( Project 3 ) where to use freerouter with a 4 layer board. The layout has two net classes. The default and the second called power which includes Vcc and GNDPWER. When I select the power type for layer b.cu then this layer is not displayed in Freerouter anymore. What is the reason for this?

Best regards


#2

You don’t mention which version of Kicad you are using. The ‘freerouter’ autorouter is an external application and not directly linked to KiCad any longer and not directly supported. I am not certain but I thought that it only ever routed two layers anyway - have you checked that you are trying to autoroute the correct pair of layers?


#3

I am using Kicad 5.0.0 and Freerouter 1.2.43 that comes with LayoutEditor.
Freerouter is only using 3 Layers, even when I setup all layers to signal.


#4

The limitation of two layer routing is discussed in this thread.


#5

If I use this version of freerouter (https://freerouting.mihosoft.eu/) then 4 layers will be routed. But the dedictated layer for power is still not possible.


#6

I made FreeRouter route a something like 10 layers.
Go into Utilities -> Parameter -> Autoroute
Then enable all the layers you would like to use :slight_smile:

I noticed it use the top and bottom layers first so just to test its function i placed a keepout area on both top and bottom layer to force the router to use other layers.

I’m all new to KiCad and FreeRouter so i might have done something entirely diffrent to make it work.


#7

Is this done with by using electronic design automation?