3D viewer (Wings 3D) crashes windows 10 KiCAD Version 4.0.7


#1

Windows 10.
OpenGL 4.4 .
Tried both 32 and 64 bit versions.
Wings 3D never opens. (Not responding).
No Error message or dialog window seen.


#2

Hi Zoe,
Wings 3D is not a KiCad related software.

Mind that in order to report official bugs you should follow the proper channels:

But in this forum we can help on get the right steps.
What are you trying to achieve?


#3

Wings is no longer the suggested software do deal with 3d models.

The currently suggest toolchain is freecad with the kicad-stepup workbench.

The mention of Wings has been removed from nightly builds and it will therefore also be removed from kicad version 5.


#4

The goal (for me) is to be able to view,export and print a 3D rendering of
a PCB


#5

I suggest you try the “Nightly Development Builds”. You can find how to install it in the KiCad’s Download website.
There you will get access to the new 3D Viewer of the future KiCad v5.


#6

Why not use the internal renderer? (Even in stable this should give quite good results.)

You can also use blender to get truly wonderful renderings. (Use the VRML export found in pcb_new and import that into blender. Then play around with lighting and shader option to get the result you want.) In fact you can use any artistic renderer that supports vrml (=wrl) version 2.0 as an import option.

If blender is too much work but stable does not give a satisfying rendering, you could use a nightly build as a compromise. (As suggested by @kammutierspule) But to be honest i would not suggest any new user to go this route as the latest nightly builds have a lot of undocumented features, come with a completely reorganized lib that is not yet fully finished, still has some bugs, …
See FAQ entry Is it a good idea to use a nightly build version?

For us to help you, it might help if you could inform us for what purpose you need the rendering.


#7

Rendering is really a misnomer. I’d like to see a 3d view and be able to print it.
When I push the 3D button KiCAD goes Not Responding and and 5 minutes I give up and shut it down. Everything else seems to work.

I’m probably missing some easy setup function but I have no cluse what it might be


#8

So your problem is with the internal 3d viewer. That is a different thing than wings!

Can you view an empty project in the 3d viewer?
If so, can you view your project in the 3d viewer if you change the environment variable KISYS3DMOD to point to an empty folder? (Changing path variables is done in the preferences menu of the kicad main window.)

If this works then one of your footprints is connected to a 3d model that breaks the kicad internal 3d viewer.
You can use the 3d viewer in the footprint editor to check each footprint.


#9

Thank you Rene:

Bnak project or environment variable KISYS3DMOD pointing to a blank directory always causes the “no response”


#10

What kicad version are you running?


#11

4.0.7 Windows 10 please and thankyou


#12

I’m stumped. I believe I try the nightly when I get a chance


#13

You might want to head over to the bugtracker. Maybe one of the developers has an idea on how to get the internal 3d viewer running again.


#14

I suggest to install and try KiCad Nightly builds. v4 is almost outdated and new bugs will need to be reported against v5.


#15

4.0.7 should work fine on Windows 10 as it does for many users.
Have you tried looking at on of the demo projects?

What is your Preferences - Configure Paths - showing for KISYS3DMOD? On a Windows 10 system this MUST be pointing at a writable directory, Windows 10 will refuse to write to anything in Program Files
When you download 3D models via Prferences - 3D Shape Libraries Downloader, make sure that the destination folder matches KISYS3DMOD and only select a few at a time, it is a very slow download process


#16

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.