3D Part Viewer/Editor inside KiCAD not working

Just installed KiCAD version 6.0.0, using Windows 10.

In the layout portion of KiCAD, when I select “Properties” on a certain footprint, then select the TAB “3D Models”, in the preview window, all I see is the pads to the part and nothing else. Even though the footprint is properly linked to the 3D Model. My ALT 3, board 3D viewer works fine. It shows all the associated 3D Models on the footprints. I’ve installed multiple versions of KiCAD, and they all have this same error inside the 3D part viewer in the layout.


Any idea how to fix this?


Does this happen with all footprints or only some official KiCad footprints? See Why a footprint points to a 3D model but the model file doesn't exist?.

This happens on ALL footprints, regardless of TH or SMD. I know that the path is good, because the ALT3 works just fine and shows all the associated 3D models on each footprint.


OK, looking at your screenshot, it looks like buggy 3D rendering. There have been similar problems which may be caused by problems in 3D hw/drivers.

Here: 3D viewer problem without raytracing

Thanks to all who helped. It was a driver issue in Radeon Pro Setting graphics card.

Created a custom profile for KiCAD.exe.

That fixed it!!!


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.