3D viewer problem without raytracing

I just installed Kicad 6 on a new laptop.
The 3D viewer does not work properly with the default settings, via the PCB Editor and via the Footprint Editor. No board body, pads and silkscreen are completely distorted.
It works fine with Raytracing enabled.

For example, if I display a resistor R_0603_1608Metric from the provided library.
Without Raytracing, default settings :

With Raytracing, same angle:

The laptop is a Lenovo Thinkpad P14s, AMD Ryzen 7 Pro 4750U. The drivers are the last ones proposed by Lenovo, windows 10.

Iā€™m stuck, I have no idea how to fix it.

Some more information:

Application: KiCad (64-bit)

Version: (6.0.0), release build

wxWidgets 3.1.5
libcurl/7.78.0-DEV Schannel zlib/1.2.11

Platform: Windows 10 (build 19042), 64-bit edition, 64 bit, Little endian, wxMSW

Build Info:
Date: Dec 24 2021 19:17:02
wxWidgets: 3.1.5 (wchar_t,wx containers)
Boost: 1.76.0
OCC: 7.5.0
Curl: 7.78.0-DEV
ngspice: 35
Compiler: Visual C++ 1929 without C++ ABI

Build settings:

Have a look on this thread:

Thank you! I had to disable the shader cache to make it work.

1 Like

What is raytracing? Where is this setting in KiCAD?


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.