Zooming is very touchy!

My Windows 10 laptop has a feature where I can scroll with two fingers on the touch pad. Very handy, except in KiCad where the zoom feature is VERY touchy. It zooms from the whole drawing occupying a tiny spot in the center of the screen to the whole screen taken up by a fraction of a pad.

Remember when your stereo had a bad volume knob and you had to tap it several times to try and get a reasonable volume? Yea, it’s kindof like that.

Is there a parameter somewhere I can adjust it? Oh. I guess I COULD buy a mouse. Have one somewhere, but haven’t seen it in about a year.

1 Like

Zoom should be adjustable in both mac and windows, but on the system side. Personally, I never use touch pad for layout but maybe that’s changing for a lot of people.

The 2-finger-touchpad-scrolling is old on the Mac but it has the same problem in KiCAD. Even with my Logitech mouse scroll-wheel it is very touchy.

I don’t want to change the system’s scroll behaviour because it is working fine in all other apps. If I’d turn the scroll speed (or scroll acceleration) down in the system setting I’d get crazy trying to scroll down a webpage or in a text document - so this is unfortunately no solution.

I’m on MacBook and OSX 10.9.5. I don’t have a mouse, and I’m happy with my multi touch touchpad. I’ve designed pcbs in Eagle, where you can easily zoom with fingers pitch gesture and pan with 2 fingers scroll gesture. But I can’t do the same obvious thing in KiCAD… Can’t even properly zoom, because it’s so touchy! And always panning with sidescrolls is painintheass…
Please, make pan and zoom in KiCad as easy and handy as in Eagle for touchpads. Maybe you can show me, where to correct some code?

In my win mobile pc, when I don’t have a mouse, I use F1 and F2 keys as workaround …

On a Mac F1 and F2 keys are for display brightness control. Fn+F1/F2 does nothing anyway… Hotkeys for zoom in and out on a Mac is on Cmd++ and Cmd± respectively. But they are zooming with a big steps, and, moreover, Cmd++ doesn’t work ><

I’m far from my mac, but I think you could re-map your keys with the kicad pcbnew hotkeys menu…
may be some mac-user could help us :smile:

Took my mouse out of my junk pile. With a scroll wheel it is a lot better, but not as good as on my touchpad in Eagle CAD. Back into the mouse age, sorry Steve…

in my mac Cmd++ and Cmd– work…
the mouse has to be in pcbnew area to work
anyway they work with big steps