Zone will not fill (but others will)

Having an issue where some of my zones are filling and others aren’t. (I would upload an image but it said I can’t since I’m new, so I’ll have to wait until i’m… not new? Here’s a link to an image).
Basically. On a layer I have several ground planes. GND and GNDA. I created a GND zone then a GNDA zone, no problems. I went to create another GNDA zone and it doesn’t fill, no DRC nothing that tells me why. I even duplicated the GNDA zone that does fill and it doesn’t fill. There’s no reason I can see. If there’s a way I can see some kinda debug log or whatever, that might be helpful. Any advice would be helpful, i’m trying to get this board done ASAP as I’m on a deadline, but this is holding me up. =(

V4.0.0 R2

As for your problem:
Having to guess (as not much is depictable from the picture) I’d say you have them all on the same priority level (overlapping zones on same layer)?
Set the ones which should be created first to the higher level, then it get’s created first.
If they’re all on level 0 it’s doesn’t really know what to do and probably takes the largest?!

right click zone edge > properties > priority level under settings

Yeah I tried every combination of priorities, nothing seemed to help. None of the zones overlap.
P0 is the highest right? Since I’m not overlapping, the priority shouldn’t matter.

I’ve had a similar problem when my zone wasn’t connected to the net. Drawing a trace to if from a pad of the same net allowed it to be filled for me.

Thanks, wish that worked for me. Actually, somethings incredibly screwed up now. Everytime I launch pcbnew, it crashes kicad.exe and won’t let me lay down any traces. Deleting the zone doesn’t help. =(

Sounds nasty, you might consider installing one of the recent builds instead of the RC2?
Another option is to go into the pcb-kicad file and delete the zone information if this is causing trouble for your system and see if the file behaves after that?
But you can still open it?

I’d copy the whole project folder for backup.
Then I’d open the project, the pcb and delete the zones and start fresh over with them…
But it’s hard to judge/advise if one can’t see the nitty-gritty details of this.

One question - looking at the screenshot from the OP again - there are no tracks in that picture?
Why is that? I can still see the ratsnest.
Did you start with the zones? after placing/arranging the footprints?
I usually do the arrangement, then the tracks and shuffle/re-arrange/delete tracks/lay down new tracks a lot before I can consider any zones/copper planes (except maybe for the GND plane). Anyhow, zones usually come last, not first.

I had this same problem and the thing that worked for me was

  1. to make a copper trace out from the outline of the chip’s footprint into the fill zone.
  2. Enter the fill zone’s settings and change “Antipad clearance” to 0. I wanted to have maximum heat transfer from the pad into the fill zone, but this might be bad for other designs of course.

Ah, slight correction: Of course it’s better to change “Pad connection” to Solid instead of lowering antipad clearance.

I have had problems with zones not filling as well. My problem was due to overlapping zone corners. I don’t mean overlapping corners of different zones, but rather, overlapping corners of the same zone. Check your fill corners by right clicking on a zone corner and select “zone” from the dropdown menu and “move corner”. You will be able to tell if corners are overlapping when you move the zone corner a little bit out of the way. If you do have two overlapping corners, just delete one of them.
Also make sure the pad connection option under zone properties is something other than “none”.

Same Problems. Make sure the CORRECT NET is selected. In one case, I had two similar nets 3.3v and +3v3. One is an artifact from an legacy schematic. Once the correct net was selected, the zone immediately filled.

1 Like

I was having this same problem, a Google search brought me here. I am using a filled zone to connect two pads. It will only fill the zone if there is at least 1 net endpoint inside of the zone. As far as I can tell, the endpoint can be either:

  1. The anchor point of the pad
  2. The endpoint of a track

Just having a single track between the two pads didn’t work, but as soon as the trace connecting the pads is not just a straight line it works (I’m assuming because this new track is actually just two smaller tracks sharing one endpoint). Alternatively, you can make the zone cover over the middle of the pad.

1 Like

You may also find this thread useful:

1 Like

I also had a problem with copper zones not filling, the solution for me was to draw a board outline (on the Edge.Cuts layer). This was the first forum post I found when earching for the issue so I’m hoping leaving this here might be helpful for someone else.

This is an ancient thread from the initial release of V4, so the discussion is unlikely to be relevant to V6 or V7
Locking now