Zone not catching all pads

Hello all,
Using 5.1.2 on Win.
I’m doing a 4 layer PCB and there are some driver chips on the Front layer. The Front layer zone extends across the entire PCB. There are lots of other pins which are GND and are appropriately connected with thermal relief connections. For some reason, the fill does NOT get pins 4,6 9 (as shown in attached screen grab).

PCBnew is aware of the GND connection as it draws ratsnest from these pins to nearby GND stitching. I had to install the traces shown to actually ground the pins.


Your zone clearance setting is too high. If you look at the shape of zone near pin 9, it’s the pin 8 which has different net that prevents the zone to get close to pin 9. Same for others, other nets and pins prevent the zone to get close.


I see that now. There are some high voltage traces so I set the clearance wide. I suppose I could make several zones with different parameters…


If you have a few net’s with High Voltage tracks, then make a netclass for those tracks, and give only those tracks a broader clearance.
You can do that in:

Pcbnew / Board Setup / Design Rules / Net Classes.

Recognizing the nets with the high voltages is easier if you label them in Eeschema.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.