Zone fill failing

Running 4.0.2 on Win7 64 bit
I have a schematic and layout.
Zone fill was working and then quit for some reason.
Erasing the layout and starting it over does not help.
I can fill a zone in top or bottom layer if I select “no net” with nothing under the layer.
If I move the filled zone to cover my components and then change it’s net to “gnd” the fill and outline disappears!

If I attempt to create a filled zone over my components and choose net = “gnd” it will not fill.
All it does is make an outline with slashes on the interior edge.
The Fill option does not do anything.

And maybe related, top layer wires will route properly to netlist imported components.
Any pads I add manually will not connect to any wire tracks in any layer.

Way past frustrating.

I will leave my githib library venting for elsewhere.

Is there any pad/track overlapping the zone that has got the same net as the zone (GND)?
They won’t fill otherwise, as they need access to the net you set them up for… makes sense, right?

Not related. :wink:
If you want that (dangerous!) disable DRC enforcement during track laying in Preferences > General “Options”

Your choice, but maybe we can help there as well :stuck_out_tongue:

Wow…thanks for such a quick reply
This has been way too many hours of intense frustration.

No pads or track overlapping anything related to the zone

I shut down everything, started a new project and the zone fill works fine.
Went in the the folder for where the original pcb file was and deleted everything related to the layout
and started over from the schem

New schem netlist
Schem DRC has zero errors or warnings.
run cvpcb again
load new netlist in to pcbenew
new components come in as expected
everything looks correct

Adding zone around components works regardless of top or bottom copper

It just does nothing when I implement Zone Fill
The fill will not happen

I am just astonished at how much effort has been put in to Kicad by so many talented people
and my hours of reading forum posts and docs and yet I still find these kinds of dead ends.
This is so fundamental that I am having my doubts about whether Kicad will ever actually work for me.
I had Kicad up and running about 4 years ago and never had any problems even remotely like this.

Any suggestions would be very valued.

Can you zip the project (with zone and set up how you expect it to work) and load it up somewhere so I can load it?

Yes, I can zip it.
As a new user I am not allowed to upload.
So how to do “somewhere”?

I sent you a message, just drop it into an email.


  1. the ‘via footprint’ is not a good idea, if you need one just hit [V] while putting down a track and KiCAD will place one for you with the correct net.
    That’s why the B.Cu didn’t fill - the ‘Via’ wasn’t attached to any net.

  2. All the devices are sitting on the Front layer and are SMDs, so no pad will come to the back, where the big green zone is ‘waiting’ for them, that is set up to be on net ‘GND’ - no wonder it doesn’t fill.
    Just redo the track from U1 pin 11 and place a via at it’s end to get the net to the back.

  3. If you move the F.Cu zone that’s at the top right of your pcb outline and place it over the devices and also set it’s zone to ‘GND’ then it will fill.

So nothing really problematic.

If you need other vias, hit up this menu:

Design Rules > Design Rules > Global Design Rules tab > ‘Custom Via Sizes’

Just add some diameters and you get to chose if you need something else than 23.6 mils/15.7mils that comes standard.

1 Like

All I can say is WOW
You made my day with such wonderful advice!
Works just like you said it would.
Thank you so much.
Far more inspired to continue now.

Need help unraveling fill zones (2 layer board)

I’m having a very similar problem but not sure if it is the same problem. I have tried a few combinations but not sure why I can’t get past the current problem.
I have used Fills in the past and even had them working here until I tried to get too fancy :frowning:

I’m using a power device with multiple output pins on 0.5mm pitch. These pins go to three 0.1" headers on Pin 2 of the respective headers(toward the top of the figure). Because of the power device, I created fill zones around each trace to add more copper to this 1 oz copper board. I started with just the top fills on the Front layer and everything worked well when all power fills are on the top layer; there is a copper fill on the back for ground.

Problem Starts:
I then tried to do a top/bottom fill to the SMD 0.5mm pad.
The device has 4 power outputs but only one of the fills is working (without the top and bottom fills).

The problems seems to start after I try to do a Top and Bottom layer fill on each of the 3 the primary output pins. Basically the Top and Bottom fills are nearly identical except where I get to the SMD device (0.5mm pitch). As close as I can to teh device I put a via to pin teh two layers together even though only the top layer gone to the actual device.

This Is what I have tried:

  • Adding thin traces to connect nets on top and bottom using a via to terminate the bottom track.
  • Changed the priority to 2 on all of these double sided power fingers. Without that back layer just gets filled with the ground plane. Top does not fill.
  • KiCad seems to get confused when I put top and bottom layer nets and connect using the via.

As JeffD this is really my final hang up to ship this board out.

The one that works is connected to PAD 10, correct?

Hm… hard to tell without touching it… any chance you can send me the project or just the .kicad_pcb file so I can have a go at it?

Actually right now nothing works. What do I do to send you a copy?


Right now I have tried several things and cannot get the double finger fills to come back. The rest are there and the backplane continues to work.

You are correct but I never tried to change Pin 10 to front/back.

It was pins 11,12, and 13 that I tried to double up on and now can’t get anything to fill on those traces.

EDIT3: I also can’t get the LiPO_GND on Pins P6-3 P7-3 to clear the ratsnest. I was clearing before. I cleared all checks and DRC before doing this last mod to double the finger traces.

The zones on F.Cu that is on Pad 11,12&13 have the wrong net applied…
got C8-Pad2, needs P8-Pad2, same for the others on F.Cu.

The ones on the B.Cu need some short lengths of track going into them… just having the zones overlap a footprint pad isn’t enough:

Also, you don’t need to draw the zones with distance from each other… just draw them side by side, KiCAD will figure out the clearance between them, depending on priority level.
That way you have less micromanagement and probably more copper and easier zone outlines:

One more note… what are the circular cutouts for?
Why not use arcs?
The pcb outline is not cleanly defined like that…
What grid is it drawn on… can’t seem to find one that matches the points of the straight lines.

Thank you very much. I’m working on recovering from the thrashing around I was doing last night. I knew I had fallen through some trapdoor but couldn’t figure out what. This is still all a little mysterious but now it all makes more sense and hopefully in the future I will have the sense to go back to basics when something like this happens.

The problem is that there is a history of quirks/issues still showing up in Google searches from only 1 year ago that might easily have been fixed by now but gets you chasing down a rabbit hole. When I google search I’m paying a lot more attention to the dates and stay away from anything over 1 year old.

On the edge cuts, I was not really sure how to deal with them. I tried to trim the circle but it would not allow. I see that the arcs are what I needed to use in the first place.

I’m also paying a lot more attention to grids now however to get alignment between three different sets of drawings (the PCB, the daughter board and the enclosure dimensions) I have had to drop to the finest grid and struggle with many decimal points to get them all aligned.

Anyway, I’m had at it trying to get these gerbers out today.

Thanks again for the fast response.

EDIT: I think I got it now

I tried to overlap fill areas for the fingers but it gave me a DCR error so I adjust the boundaries to avoid DCR errors (at little more work but a joy if you want to be anal :)).
I wonder if that is because I do not have a prioritization set?
How do you make those PRIO labels visible?

1 Like

post processing with a paint program :wink:

This topic seems like it should be all I need to know about getting fills to work. And indeed it helped get two of them to fill. But I have one zone (what appears to be the simplest of all) that refuses to fill! There are just two pads involved and a simple rectangle is all that’s need to connect them. I have the zone on the same net as the pads; the pads are connected with a trace. But it won’t fill! What should I check next? (I even reduced the clearance, set the priority to “1” (although that shouldn’t be needed) and set connection to “solid”. Nothing helps. What am I doing wrong? The board is attached.
StepUp_1Amp.kicad_pcb (29.2 KB)

For some reason the zone won’t get filled unless either the center-point of a pad or the extremity of a segment of a track (connected to the zone net) are inside the zone boundary. In your file, these conditions are not fulfilled.

Here the cleanest solution is to add more corners to your zone to enlarge it, and make sure that it includes the center of U1’s pin 1.


Thanks! I can try these things and I suspect they’ll work.

Your comment “for some reason…”. The reason is that both this awkward zone filling AND the way odd shaped pads have to be made are both kludges. Two kludges rarely equals an elegant solution!

Note to Kicad devs: Make simple things work correctly, only then add gee-whiz features. Seems like the basics are being ignored in new development. Polygons need to work easily both for pads and for fills.The schematic editor works just fine!

odd shaped pads = more than basic shapes (circle, square, rectangle and oval)
The devs seem to stick to KISS already.
The basics work fine on my end, though I would also like odd shaped pads from time to time.

awkward zone filling?
You mean that it needs to see a pad center or track to get filled?
What good is a zone for a certain net if there is no contact with a pad or track to it?

And the schematic editor is ‘old tech’ with a couple of things that are outdated and will become OpenGL at some point in the future.

Joan, I’m sure the devs appreciate your almost-slavish devotion to their defense. But polygon-shaped pads are BASIC, not advanced. And using a polygon-shaped fill to connect zones should be as simple as connecting to the pads involved. EAGLE seems to have no problem with that concept. Why should a trace connection AND connection to the center of a pad be required. Just makes Kicad hard to use and tricky for a new user - pointlessly.

Sorry if it sounds like I feel strongly about this but I do. I want EVERYONE to be able to use Kicad easily. I teach others how to use it and I hate to have to explain clumsy, kludgy work-arounds for simple stuff that’s needed in nearly every surface mount design. Polygon pads and fills are basic in such work.

No need for further defense, Joan. Kicad is a great package. We both want it to be better, but the devs are not necessarily the only ones who should decide what the priorities are for development.