XML parsing error: 'no element found' at line 1

When I go to Assign Footprints I get an error box pop-up
XML parsing error: ‘no element found’ at line 1
Any idea what the problem is and how to fix it? I am very new to KiCad so it may well be something I have done wrong, but I have no idea what it could be.

system info -
Application: kicad
Version: 5.0.2-bee76a0~70~ubuntu18.04.1, release build
wxWidgets 3.0.4
libcurl/7.58.0 OpenSSL/1.1.0g zlib/1.2.11 libidn2/2.0.4 libpsl/0.19.1 (+libidn2/2.0.4) nghttp2/1.30.0 librtmp/2.3
Platform: Linux 4.15.0-45-generic x86_64, 64 bit, Little endian, wxGTK
Build Info:
wxWidgets: 3.0.4 (wchar_t,wx containers,compatible with 2.8) GTK+ 2.24
Boost: 1.65.1
OpenCASCADE Community Edition: 6.9.1
Curl: 7.58.0
Compiler: GCC 7.3.0 with C++ ABI 1011
Build settings:

Where and how are you assigning footprints?

Where: Eeschema, CvPcb, Pcbnew, other?
How: There are multiple paths to assinging footprints in these programs.

I have created a scheme and use the ‘Assign PCB Footprints…’, then select the footprints. There are only 2 components, one existed in the library, the other, DS9503 I imported from here https://www.snapeda.com/parts/DS9503P%2B/Maxim%20Integrated/view-part/?ref=search&t=ds9503 I think the import was OK but maybe that is the problem?

What happens if you delete the snapeda footprint?

jfmateos also had a problem with snapeda, and he apparently managed to solve it himself.

I’m getting a bit sleepy now, and encountered this half typed post…
DS9503 Zener diode has a simple 6-pin SMD package, but I did not see it’s measurements in the datasheet. If you know it’s measurements you can design a footprint for this component in about 2 minutes with one of KiCad’s Footprint wizards.
Bedtime, maybe more tomorrow.

Thanks for you reply. I deleted it and tried again a few times, I still get the error message but it does seem to work now. To be honest I am not sure what I changed to get it to work, but I have imported from snapedia and it worked, so for the moment at least I will just ignore the error message.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.