wxWidgets war story

According to Adam Wolf and some of the other nice folks over at the #kicad channel on freenode, wxWidgets has caused a LOT of problems for the builds recently. If you’re on 14.04 it requires a secondary backport ppa in order to work properly.

Last night, I gave up the fight.

On my 14.10 Ubuntu VM, I had problems where the copper pours would crash about every 3rd time I tried to fill them. I caught many of these on camera while I was filming for Contextual Electronics (fun!). After some investigation, it turns out that I had multiple versions of wxWidgets, likely from when I was still doing the kicad-install.sh script method of installing. I had tried a couple of apt-get builds in the process of doing that (because of error messages), so I’m guessing it was actually my fault in the end. However, it looked like I had version 2.8 AND 3.0 of wxWidgets on my machine. I now use the js reynaud nightly builds, and it was expecting 3.0.1 for wxWidgets. So it was probably something in there.

The long and the short of it is: I gave up. I started up a new VM, installed 14.10 from scratch and re-installed the nightly build of KiCad from the js reynaud ppa. Early testing indicates that it works much better and other people on Twitter and the kicad IRC seem to concur that there are far fewer issues. It’s unfortunate that I had to give up, but I suppose that’s the benefit of a VM vs having to reinstall an entire system. It’s also a bit annoying that this kind of stuff happens, but with the pricetag and the bounty I have received from using KiCad so far, I’m the last person who is allowed to complain.

Just wanted to document my woes here. Sometimes you gotta start fresh.

Hey Chris,

Thanks for all you do to teach and promote KiCad.

I was wondering what type of VM software do you use? Is it a freeware type or pay version?
I am setting up a new Windows 8 computer that is pretty powerful and would like to try out using VM to “safely” test software and be able to blow it away without any leftovers.

Do you see that as a good use of VM?

Thanks for any guidance you can provide.

PS I don’t mean to hijack your post… If this needs to be moved to another topic let me know.


Definitely a good use, you can try out a bunch of different distros of linux or otherwise. I use VirtualBox on my Windows machine and I use VMware on my Mac.

Did you try to remove the -dev packages for wx2.8? That would have made it impossible to build anything with 2.8, and left you with linkable 2.8 libraries for existing applications. My log book says I did this for my recent build of kicad from source, although I’m not sure if it was because I had problems or not. If you still have the trouble VM image around, it might be worth trying for the benefit of those with similar problems if nothing else (esp. if they aren’t using a VM). Also definitely “make clean” before building.

Hello Chris,

this ia a little bit off topic but I am wondering why you are using KiCAD from a VM instead of using the native MAC version which is now available? http://downloads.kicad.org/osx/


Accessibility for Contextual Electronics. Anyone can get started with Ubuntu/Linux. Not everyone has a Mac (though I do now), so I want to experience the same things members of CE might experience.