Wire not connecting to hierarchical label


#1

The little squares at the end of the wires refuse to click into the square of the hierarchical label (screen shot below).
Of course the ERC says “Pin 13 of component U1 is unconnected.”

I read the manual and fiddled with it. What did I miss?

Thank you.


#2

Set grid as 50mil (and never change it!) and redraw your schematic from a scratch.


#3

My Schematic Editor Options says “Grid size: 50.0 mils”.
I never changed it.


#4

Your wires were drawn when the grid had 50mil. The sub-sheet symbols were not.


#5

The sub-sheet also says “50.0 mils”, and I never changed them.


#6

It seams that you had your grid set to 25mil some time back.
red lines: your current grid
blue lines: additional grid points you would get if you set your grid to 25mil

You have some options going forward.
option 1: do what @keruseykaryu suggested.

option 1a: maybe don’t redo everything. you can set your grid to 25mil temporarly and move everything that is not on the 50mil grid so that it aligns with it.

option 2: if you don’t care about the looks of your schematic, just set your grid to 25mil and stay with that.


#7

I’m talking about the symbols not sub-sheet itself.

Or keep 50mil grid and try to move and resize sub-sheet symbols to automatically re-align them to the current grid, then re-align sub-sheet pins.


#8

I took keruseykaryu’s advice and redrew my schematic from a scratch. And it worked.
I must have changed the grid size some time ago, and forgot about it.
Thank you for your patients.


#9

Hi there,
this happened to me right now when I was changing the orientation of the hierarchical “sub” sheet. The pins and the edges went off the grid (:smile:). I didn’t want to redraw everything. I have found out that all the other connections are on the grid because their locations are a multitude of 50. But this subsheet on the root sheet, things are at “xx36”. I replaced “36” with “50” in text editor. It worked for me.

When I rotate the object and things went off grid again. It is a bug I guess.


#10

Yes, there is a bug when rotating sheet symbols, I’m sure I saw it on the bug tracker.


#11

Specifically rotating hierarchical sheet blocks and the bug has just been fixed