Wire links aka tutorial issue

hi all. I tried to use the wire links that went with the tutorial on creating models for kicad with freecad. for a single sided board I am working on. If I look at the model in freecad it shows just the wire. If I look at the model in kicad 3d viewer it just shows the holes, pads and silkscreen, but does not show the wire itself. Could someone point me what I am missing in how to get both to show the wire and pads, holes and silkscreen. thanks.

The pads and Silksreen, etc on the PCB (Everything flat) are part of the “Footprint” itself.
The wire you see in FreeCAD, is the 3D model.

If you do not see the 3D model in KiCad’s 3D viewer, then the most likely cause is that the link between the footprint and the accompanying 3D model is missing.

To take this switch as an example:

image

If you select a footprint in Pcbnew, and press e for edit, you see the footprint properties, and the window has three tabs:

  • General
  • Local Clearance and Settings.
  • 3D Settings.

The “3D settings” tab has the information to the footprint link, and if that link works you can see the preview.


Now I have to be quick, cause BlackCoffee is also jumping in :slight_smile:

1 Like

All depends on what files/download you’re using…

But, if referring to My tutorial and jumpers (.zip), I just downloaded it and copied a jumper and .mod to my junk folder. Then, placed in on PCB. No problem… shown below

EDIT: The .mod contains all the Step/placement info. You shouldn’t need to do anything except place it on a PCB

EDIT#2: Here’s a link to the Kicad Post with the .ZIP

EDIT#3: Figured I didn’t need to say but, will anyway… The Step/WRL/.mod (for any Model/Footprint) needs to be in a folder that Kicad has access to. Otherwise, you won’t get the full Enchilada…

1 Like

thanks guys, it’s showing now. I must have moved the wirelinks into a subfolder, and though kicad still showed the footprints it didn’t find the step files. I had to fix all the links to sort it. now to figure out how to adjust the wire height. I tried adjusting the z axis offset in the 3d settings, but it didn’t appear to do anything.

It works fine (just checked it)

Your screenshot shows Two of them - one checked for preview, other not checked.
Only need one of them. Delete the bad one.

Also, look at the X scale should be 1.000, not 1.100…

Ensure correct/desired settings…

1 Like

I did that (removing the incorrect item, not just unchecking it), fixed the x-scale, and the the z-axis offset then worked. thanks for the help.