Windows nightlies


#1

Might be off-topic, but does anyone of the sages and gurus here know why there are no new Windows nightlies since May 15th?


#2

Nothing in the developer mailing list and there have been relevant commits in master source and a lot going on in libraries


#3

I’m currently running:

Application: kicad
Version: (2017-05-12 revision b823d0b78)-makepkg, release build
Libraries: wxWidgets 3.0.2
           libcurl/7.52.1 OpenSSL/1.0.2k zlib/1.2.11 libssh2/1.8.0 nghttp2/1.19.0 librtmp/2.3
Platform: Windows 7 (build 7601, Service Pack 1), 64-bit edition, 64 bit, Little endian, wxMSW
- Build Info -
wxWidgets: 3.0.2 (wchar_t,wx containers,compatible with 2.8)
Boost: 1.60.0
Curl: 7.52.1
KiCad - Compiler: GCC 6.3.0 with C++ ABI 1010
        Settings: USE_WX_GRAPHICS_CONTEXT=OFF
                  USE_WX_OVERLAY=OFF
                  KICAD_SCRIPTING=ON
                  KICAD_SCRIPTING_MODULES=ON
                  KICAD_SCRIPTING_WXPYTHON=ON
                  KICAD_SCRIPTING_ACTION_MENU=ON
                  BUILD_GITHUB_PLUGIN=ON
                  KICAD_USE_OCE=ON

…and have to say it’s stable and usable - knocks on wood. Did a single A3 sheet design over the last 5 days with it and I’m nearly done with the layout in Legacy Canvas (can’t talk for OpenGL as I didn’t use it).
No problems what so ever - computer was running non stop and so was KiCAD.


#4

I tried that right now. I take it that the drill file generation works in your configuration. Mine crashes KiCad (Windows 10).
Why not revert to my proven 4.0.6 and use my backups? Sigh …that’s a long story with some embarrassing details ;-).

I’ll rest the case for now and wait. No problem, as I am in Hobbyist mode in the project concerned.

Thanks for inputs, anyways!

[EDIT] r8047 (Apr 22th 2017) works, no crash generating drill files, and it happily digests my board. So no problem whatsoever.


#5

If this is a reproducible bug, it would be nice to report it


#6

It is reproducible with a tool of 185.xx mm diameter showing up in the .rpt file and somewhere amidst the drill file an Y coordinate of 97.0 truncates to 97. and the the next entry wracks havoc, showing an Y coordinate somewhere in the stratosphere.

Ok, not your story. I’ll file a bug.

[EDIT] It’s already in the bug list, fix committed and under review.


#7

The drill file bug and commit is the reason that there should have been at least one valid build since the 15th


#8

Bumping this, still nothing since the 15th.
Developers @cbernardo or @nickoe might be able to comment?


#9

Has anybody already made a bug report about this? If not might be a good idea.


#10

It looks like the windows build servers have been unavailable since May 16 http://ci.kicad-pcb.org/job/windows-kicad-msys2-nightlies/


#11

Raised https://bugs.launchpad.net/kicad/+bug/1693184
but @bobc seems to have spotted a build server failure. What that actually means???


#12

Any news? Two weeks have passed…


#13

The mailing list reports progress with MacOS and Debian builds, no mention about Windows


#14

Lots of time have passed where no one sent me chocolate.

The windows nightlies are up again anyways. Please test.


#15

It’s working!
Thank you.


#16

So far so good, what happened?


#17

Thank you! I’m downloading now. :slight_smile:


#18

No further updates, so presumably still not healthy


#19

What do you mean? Fjfkfkfkd


#20

Windows build servers still not running
1 new build on 31 May, but nothing since.

http://downloads.kicad-pcb.org/windows/nightly/

Are we looking at the same thing?