Window size quadrupled (Linux, X11)

When I try to maximise the size of a KiCad window (using the button provided by the window manager), I find that KiCad resizes the window to four times the size of the screen (twice in each of the two directions). I tested that on two machines with different monitors. For instance, KiCad resizes the window to 7680 * 4320 pixels (including border decoration) for a monitor with 3840 * 2160 pixels. How can I turn this “feature” off?

KiCad records the quadrupled window size in the KiCad configuration files as KicadFrameSize_x etc. Fixing those does not help.

xdpyinfo and xrandr report the correct screen size in number of pixels. KiCad is the only application on my machines showing this behaviour.

Besides, does KiCad provide an option to remove the window decoration whenever a window has been maximised?

Gentoo (amd64)
x11-libs/motif-2.3.8-r1 (using mwm)

KiCad 5.1.2
xfce on 18.04 LTS

Just confirming the effect. In one instance I had exactly the same. It looked like something switched into pan mode. Did push the home button, zoomed in/out a few times and it went back to normal.

xdpyinfo shows double in x-direction with y-direction at exactly the same as the monitor itself.

With more than one monitor KiCad seems to focus on the one monitor worked on. It does not spread across multiple monitors. Then again multiple monitor behaviour is defined by X settings.

I don’t think it’s KiCad itself rather a mode setting within X.

I found this problem on two different PCs with almost identical software, but different monitors. One of my machines has an Nvidia GPU installed, but I removed the GPU from the second machine a while ago (had nothing to do with KiCad). Nvidia drivers, Cuda etc. has been installed on both machines, but no X11 server has been started (even not on the machine with its card installed). I use the i965 GPU of the processor on both machines.

On my machines, xdpyinfo reports the correct number of pixels, not quadrupled.

And, KiCad also opens those quadrupled windows by itself, as long as I don’t resize them. The maximize button is just one way to reproduce the issue.

I’m running KDE and I’ve never seen that behavior with KiCad (or any other application). Nor have I seen it with Linux Mint with the Cinnamon desktop.

Are you running Xubuntu, or did you install the Gnome-flavored Ubuntu and add the XFCE desktop to it?

RRPollack, although you use KDE, KiCad may be linked with wxGTK on your system and therefore also with GTK 3. Wxwidgets supported Qt only as an “experimental” option back in 2016. I am not sure if that has changed since. Wxwidgets allegedly also supports Motif, but that option has been neglected for a long time. Personal note: I don’t like wxwidgets.
About your “Ubuntu”: I am using Gentoo, as I already stated.

Back to the topic, which still persists: I have updated my systems to wxGTK 3.1.2 by now (something not in the Gentoo repository “portage” yet) and gtk+ 3.24.8. No change. But I did find that filezilla (3.41.2) shows exactly the same behaviour! KiCad and filezilla are both linked with wxGTK. All other applications without wxGTK are fine. That makes wxGTK my prime suspect for now.

I don’t see how I can find the cause without debugging. Does anybody have a setup for KiCad in Eclipse on a Linux system at hand?

Another issue (off topic): KiCad sometimes leaves artefacts on the screen when it creates new windows. Those artefacts vanish after an xrefresh. I haven’t seen anything like that since the early 90th. In one of the KiCad tutorials on Youtube someone found by chance similar behaviour on a Windows machine. I blame wxwidgets for that.

BTW, there is a job opening at Xilinx for a software developer with wxpython experience since end of April. Seems that they want to throw more wxpython at Vivado users (me being one of them).

Take a look in your ~/.config/kicad/pcbnew file and look for these lines:


This is how KiCad keeps track of what size window was open the last time, and will reopen at the same size the next time the window is opened. Do these sizes match the size of the window you’re seeing?

I already did that. All entries for *FrameSize_x and *FrameSize_y are wrong (doubled for new or maximised windows).

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.