Why will my NETs not join both ends

Hi only just started to use KiCad. Tried just jumping in but had problems so tried the design made from the help file, still same problem.

I can make the Schematic, join my Nets, but here the problem starts. No matter how much I zoom in I still get unconnected nets, nearly all.

Cant find a way to correct this any ideas please?

thanks in advance M0VLK

From the menu select “Preferences” -> “Schematic Editor Options” and reset the grid to 50 mil. Then redraw your schematic. When drawing your schematic you will notice little squares on the end of wires and little circles on the end of pins, these indicate that the wire or pin is not connected.


Adding to what @1.21Gigawatts wrote:

EEschema in its current state lacks the functionality to snap to anything other then the grid. This means anything that you want to be connected must be on the same grid.

So the first step needs to be to decide on which minimum grid you want to use. Design your personal symbols such that pins are on that grid or on any larger grid. (Example if you use 50 mil grid in eeschema you can connect pins on 50 mil or 100 mil grid)

While working in eeschema make sure you never switch your grid to a smaller value than the grid you decided to use. (At least not while placing symbols or traces) This will ensure that you can always connect everything with the grid you choose.

As @1.21Gigawatts already wrote a good grid to choose is the 50 mil grid. All symbols in the official lib are guaranteed to be compatible with 50 mil grid.

1 Like

Many thanks all for the info.

It was that the grid sizes were mixed and I was not placing the items in the grid places.

Now, with more care, I have made all work.

Thanks again all M0VLK

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.