Why the track line is routed as 45' degree in the chip's pad?

Hi ,guys.
I am using Kicad 5.15, it’s an awesome software.
I have not changed the setting, some times the chip’s(QFN24) pad will track as a 45’ degree line, I have to press ‘/’ to move it to 0’ degree:
PICTURE
how to change this to 0 degree? thanks .

Seems still have to press ‘/’.
I suggest the trace line should not use the current grid setting.
I have used PADS/ALLEGRO/AD, none of them will act like this.
But thanks anyway, hope some changes in furture.

The issue I pointed to is fixed IN THE NEXT VERSION.

First:
Try to be careful with KiCad version numbers. There is no KiCad V5.15, so I assume you use the current KiCad V5.1.5. (With other versions of KiCad the gamble is a lot bigger).

You can influence the behavior of how tracks are routed via:
Pcbnew / Route / Interactive Router Settings…

Ironically the behavior in KiCad V5.1.5 seems to improve if you disable “Optimize pad connections”, but I have not experimented enough yet to be sure.

Other things that may help:
Do not use a grid that is much smaller then needed. A grid smaller then approx 0.25mm or 10mil has no benefit for most boards. Setting the grid to the most often used track with + clearance (+ tolerance?) may be beneficial.

When your components are on the grid routing is (a little bit) easier. If the majority of (high pin count) components are metric, use a metric grid, for inches, use mills.

The bug report I linked got fixed with priority changes within the pad entry optimization. (If i remember it correctly) This would explain why disabling it seems to fix the problem in at least some cases.

1 Like