Why some 3D components are missing from Step file export?


#1

Hey guys, first time user here… great stuff

I am trying to export my PCB design as step file. When I check the file some of the 3D models are missing from the board, even thought they show when I check on the 3D view in Kicad.

When I go to export the step file, it says “component U2 missing model” . Where is it missing from? I have already added it in the Footprint Proprieties.

Thanks!

Edit:
I messed around a bit, it still doesn’t work but now it doesn’t show the “missing model” warning… I think it had something to do with the netlist.


#2

For the step export the model for every footpritn must exist in step file format. The 3d viewer might show you the wrl file. (The footprint can be setup for the wrl model. The step file ending will be automatically substituted)


#3

That worked, thanks man!

Only thing is, now my file went from ~15MB to 130MB… Oh well


#4

STEP files are large, this is why the V5 installer is so much bigger than the V4.0 7


#5

It is so large, to the point, I think installation should have option for user to opt it out, or download them on demand…


#6

Gotcha. I think my problem is not being able (or not knowing how) to reduce the step files for these two components. Whatever I do, the component won’t let me remove the mesh (wireframe) and just be a solid. But that’s another problem… a FreeCAD problem. I’ve never put in the time to learn 3D CAD modeling properly, but for all intents and purposes, this file will do for now. Thanks for the help and clarifications.


#7

You could test if kicad stepup reduces the size even if you include all parts. Stepup also allows you to set size limits for which parts to include. It can also generate bounding box models to reduce the resulting file complexity.


#8

you may have a look at: