Why is Gerber Viewer converting arcs to straight lines when exporting?

I’m trying to use Gerber Viewer to take an old .TOP gerber file and import it to KiCad using the Export to PCB Editor option so I can edit the copper. When I export it, it takes the arc traces around each via and converts them into straight line traces, resulting in my vias having 16 sided polygons around them instead of circles. Any help is greatly appreciated!

This is a long standing issue

I have No problems with Via’s placed on PCB, making a Gerber and exporting from GerbView To PCB. Screenshot shows no arcs.

Also, as a confirmation, I loaded the Gerber into CoppeCam and No problem (I did not bother with loading the drill the Holes… last image

IMPORTANT: What version of Kicad are you using?
You might want to post your Gerber file…

Zoomed-In view of one via

Result in CopperCam

This problem is vice versa, the OP asked about gerber → pcb, not pcb → gerber. They are related, though. On the other hand, it may be pretty nigh impossible to export gerber contours (made by copper fills in the original pcb software) to any kind of working zones in KiCad. Zone outlines don’t have any representation in gerber, only the filled areas have, and it’s impossible to know which gerber items belong form a zone and what should be its boundaries.

I created a PCB and added Vias to it.

I exported Gerbers of the PCB.

I opened the Gerbers in Gerbview.

I File>“Export To PCB Editor” (from Gerbview).

I opened the Exported PCB. You see the results.

ADDED: I now took a 6yr old Fritzing Gerber, opened it in Gerbview, File>Export-to-pcb. Opened the Exported PCB… no problems…

ADDED: My very old files are archived and I don’t want to bother with them. The oldest NON-Kicad Gerbers I have on current machine are from 2017.
Reading the Gitlab post, I see that Arcs on traces were also a problem so, I grabbed an old Non-Kicad Gerber with Radiused Track (corner) and Exported it from Gerbveiw.
Opened the exported PCB in Kicad… No arc’s on the radiused trace corners…

I suspect it’s users’ Gerbers causing the problem…

Hi, thanks for taking the time to respond.

I am not able to post the Gerber file, but I will attach screenshots of what I am talking about.

Here are three vias as I see them in the PCB Editor after exporting.

The original Gerber file was created using an old version of OrCAD, and I’m not sure what version was used.

Here is my version info copied from KiCad:
Application: KiCad (64-bit)

Version: (6.0.6), release build

wxWidgets 3.1.6
libcurl/7.82.0-DEV Schannel zlib/1.2.12

Platform: Windows 10 (build 19044), 64-bit edition, 64 bit, Little endian, wxMSW

Build Info:
Date: Jun 26 2022 02:39:06
wxWidgets: 3.1.6 (wchar_t,wx containers)
Boost: 1.79.0
OCC: 7.6.0
Curl: 7.82.0-DEV
ngspice: 37
Compiler: Visual C++ 1929 without C++ ABI

Build settings:

Here are the same three vias as I see them in Gerber Viewer before they are exported to the PCB Editor.

Without a posted Gerber I can’t help. But, I can say this:

Aside from the ‘This and That’ of why it’s happening, consider that you’re looking at Zoomed-In photos, which is akin to looking at the City from a Street, of course you’ll see rut’s in the road.

Zoom-Out and you’ll barely notice them, if at all.

And, you wouldn’t see them on a PCB for a Via!!!

Regarding a comment about a Fab house charging extra for this condition, I’d find a different Fab (be sure to clarify for them that they needn’t worry about it as they might be thinking you really want them with straight lines, thus causing heartburn to manufacture…)

That’s right, KiCad exports arcs from gerbers to a bunch of straight lines. But even if they were arcs, how would you use them? You can’t edit such a board because you can’t refill zones. You have to delete all these items which were originally filled areas in the original software and recreate the zones from scratch if you want to move tracks or vias or pads.

BTW, Kicad even itself uses straight lines in filled areas. In v5 it used the same strategy than Orcad seem to have used: it surrounded the contours with lines. Orcad just uses arcs instead of only straight lines. The gerbers exported from KiCad PCB looked like what your gerber → PCB file result looks now: the exported gerbers had a large amount of short straight lines around arc shaped objects. This is an option in v6, but by default it just creates polygons with straight edges instead of adding the line segments.

Well, the ability to read meaningfully is an important cultural technique. I for sure failed at that in this case :slight_smile:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.