WHy does Eric tell me all the connections are not connected

I have a schematic that shows all the wires connected. When I run Eric, I get a ‘not connected’ error for every connection. However, when I go to PCB layout, most, but not all, of the wires are there. I also have 464 warnings that pin or wire is off the grid.

I have a couple of relays, and I guess KiCad does not like relays. None of the wires connected to the relays on the schematic appear in the PCB netlist.

How do I fix this situation so I can layout the board and feel confident that all the wires are there?

Move all your symbols to a 50mil grid.
Make sure all your wires in the schematic are really connected (no squares).

How do I “move all your symbols to a 50mil grid”?

This is an extremely common problem, and gets asked about many times per year. Here is a recent link:

I still don’t get the 50mil grid part.
Screenshot from 2023-08-31 18-23-14
This is what I see under grid settings. The drop down does not have a 50 mil option.

I am using KiCad 7.0.7

50 mil = .0500 in. = 1.2700 mm.

50 mil. = 50 thousandths of an inch.

See your “Fast Switching” Grid 1. Currently you are using a grid of 0.01 in (.254 mm) which is twice the size of the recommended Schematic grid.

Do I change everything to 50 mil?

KiCad is a bit weird, in that if you switch the units (mm, mill, or other banana units) with the buttons on the right side of the screen (The tree arrows), then it also uses those units in other parts of the program (such as with displaying grid resolution).

Also, grid coordinates have to fit perfectly. In the resistor below, on the right side you see a small square and circle. This means that KiCad does not recognize the connection (because the coordinates do not match). The wire on the left side is accepted because the circle and the square disappear.

1 Like

I already wrote that 50+ times on the forum, inclusive in the link 3Dogs posted earlier.

And this is just as frustrating for me as it is for you.

I guess it’s more frustrating for you then for me, and I guess you have been working on this from before the first post in this thread, so for more then an hour, it’s probably time to go take a break and do something else for a while.

And when you come back, follow the link 3Dogs posted and read what I posted in that thread.

I did…even took a shower!

Still working on lots of issues. I got the grid sorted, and the errors went way down. And no boxes!!

I get the attached File Warning every time I open the schematic. Even after a reboot.

Any ideas??

I also have a lot of wiring errors like the second picture.

Q4’s emitter is tied to ground…not sure what all the fuss is.


Where did you get the 2N2222 symbol? Obviously you don’t want Open Emitter type for the emitter pin. Change the pin electrical type to Passive.

For common transistors I just use a generic transistor symbol and edit the value field to the model number. No need to go looking for a specific symbol for some model that’s rarely seen, or even commonly seen.

About the “already open” thing… KiCad uses lock files (with the extension .lck) and such a file can be left behind when KiCad does not close properly. You can exit KiCad, and then delete that file and KiCad will not nag you anymore.

That 2n2222 is definitely not from KiCad’s default libraries. So you have at least two options. Use one of KiCad’s standard symbols and change the “value” field (which is the “type number” for a transistor, but the real value for capacitors and resistors) or you can use your existing transistor, load it in the symbol editor (hover over it and press [Ctrl + e] and then set the types of all pins to “passive” (which is used for KiCad’s standard transistors).

Also: with the “european” resistors you can put the value nicely inside the resistor itself, and this can save quite a lot of space on the schematic. See my earlier posted screenshot for this. Americans use some kind of spiky inductors for resistors and then this does not work. At least, that is what they do most of the time. but sometimes:



I just used what I thought was a generic npn transistor, and changed the value to be 2N2222.

I guess I missed the note that it was only for simulation. My bad.

I will go in and change all the pins to passive for all my transistors. I have some PNPs as well.

I will look for some .lck files and delete them.


The right foot is the one where the big toe is on the left :slight_smile:

Only symbol pins and wires at schematic have to be at 50 mil.
Texts at schematic need not to be and nothing at PCB have to be at 50 mil.

No! that would be the wrong foot. :neutral_face:

1 Like

No, not that right side of the screen, the other right side of the screen. :slightly_smiling_face:

Actually, zizags are a stylization of wire-wound resistors, and the (stylized) coil loops of an inductor are an (orthographic 2D) projection of a (3D) helix. The more current semicircle windings are somewhat more difficult to explain…