Why can't I make thermal reliefs?

Using version 6.0.0.
I am an experienced KiCad user. Occasionally I have problems with thermals, and I will admit that I do not understand the solution in most cases.
I am going to attempt to attach this project. You will see that it’s four layers, and I have flooded all four layers with GND copper.
I cannot get any of those layers to create thermals. I have tried to edit individual pads to over-ride the global settings, and I’ve tried changing the settings of the flood copper.
If someone can look at this and help figure it out I would appreciate it.
Thanks in advance -
DanTCPD_100W_Input_PTU.zip (819.3 KB)

Just making sure: do you rebuild zones after changing thermal relief settings? Press ‘b’.

Remark one: There is no version 6 of kicad. What you use is a development snapshot that is build every night (hence the name nightly). The current release is 5.0.2. The next one will be 5.1.0 which will be very similar to current nightlies.

You selected Thermals for PTH only which means smd pads get solid connection (unless overwritten in the pad settings. Like you did for J16)
You also have thermals on the connector J16.

Did you refill the zone after doing changes? (shortcut B) If i refill your project with current version 5.0.2 (nightly tagged as 5.1.-rc1) i get thermals on all THT pads (which is how you setup your zone)

So i guess your particular nightly has a bug here. Make sure you use the most recent one (should now report itself as 5.1.0-rc2) or if you are not really prepared for the risks of running nightlies then i suggest to switch to stable.

Rene was on the right track. Turns out it was a bug with this nightly build. Installing a new (nightly build) and the thermals are all behaving normally. Thank you everyone!

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.