White background for printing?

I want to print a screen capture of my board, but I am afraid that my Ink jet printer is going to print black background as black. Black back black
How to get recent colors?

That would be very unlikely. However, there are quite a lot of settings in KiCad’s printing dialog, and If you’re that worried a bout a bit of ink then watch your printer, and abort the print if it’s paining the whole page black.

Alternatively, you can print to pdf, , SVG or some other format and then use some other program to print, but I would not be so worried about it. Last time I printed a PCB was probably in 2017-06 during the test fitting tutorial.

Also, for myself I’ve bought a second hand laser printer a long time ago. The ink (toner) never dries out and cost per page is negligible.

Ink jet printers are sick result of the consumption economy. Horribly over expensive ink, and that combined with a big sponge in the printer to absorb al the extra ink for “cleaning cycles”.

2 Likes

I don’t think it’ll print the board’s background as black.

I made a small test print and it had a black background. I took a screen capture from the screen, pasted it to the Irfanview, and printed it in a small size.

Print on the File menu lacks some details, like net names. Its not good for general “show everything” print.

To Paul: Ink jets have + and - sides. They have nice colors. I have made some nice prints from my photos with glossy paper and a good ink jet printer.
Cost is high, yes.

What options did you use?
In KiCad’s print dialog you can choose between B/W and Color, and when printing in color you can turn the background either on or off.

I can’t check it now, but I think that background option was inactive/greyed out.
And Print dialog is not nice for a general prints. Some things which are visible on the screen are not in the prints. Print dialog is probably for making PCB films.

Here’s one quick test, plotted to PDF and printed to PDF. Print was “Black and white”. The “Print backround color” option is available only if the output mode is “Color”. Plotting and printing have differences, but neither make the background black with the options I used.

The “Print background color” option is available only if the output mode is “Color”.

Thats only 99% true. There was a bug in older versions which checked "Print background color” option for black&white and at the same time greying out the option (so the user was not able to uncheck). This could result in black background printed.

As we don’t know the exact version of the Ops Kicad-installation we can’t say if this unhappy case applies.

I have newest version for Windows, 6.07
But I can’t check that option and its behaviour now, besides I’m in a hurry

Please, let us know the outcome once you you’ve tried it out.

I will. Probably Sunday?

I would test by printing to a PDF file and seeing how it renders.

I got a print with white background. It wasn’t a screen capture but good enough, when I found good settings.

Can you describe some troubles you had while doing this and how and with what settings you solved them?

There are a lot of people searching this (and other) forums, and such info lets them find what they need without even having to ask a question.