Where KiCad could hide Footprint library contents?

I frequently copy some *.kicad_mod files from KiCad libraries to my libraries then change names and… I didn’t noticed any problem with it till today.
I decided to move some footprints from one my library to another.
Using KiCad tools (Save as and Delete) I moved 3 of them. Then decided to move the rest with file manager. I have done it, but KiCad Footprint Editor showes me like I didn’t moved that footprints (they are in old lib and they are not in new lib). Trying to open in old lib an unexisting footprint has no efect. I have switched the computer (Windows 7) off and on again (twice) assuming that KiCad will have to reread files in directories to show the lists in libraries but nothing have changed.
Where he could keep it. What file I should delete to make KiCad reread directories.
I am very surprised as I supposed that each time I run Footprint editor the lists are generated from file system.
It worked that way till now, but till now I never moved footprints from one my library to another, I only copied from KiCad libraries to mines.
KiCad 5.1.2

I have searched for one of footprint in question name in:

  • Kicad installation directory
  • AppData/Roaming/kicad
    with no success.
    This file move I have done using FreeCommander. To be sure I am not cheat by it I looked at directory contenets using Windows Explorer - all files are where I think they are.

I just don’t believe in what I see. So where from KiCad could get his library lists.

Did you restart kicad after touching the files externally?

As I have written - I restarted not only KiCad but the whole computer.

Haveing that situation I reported a bug (including screen shots):

Then when current situation was doccumented (can’t disapear suddenly) I decided to do some more experiments which alloved me to find the way-around and I added a comment to my bug.

My conclusions are:

  • if I move footprint then Footprint editor has a problem with it,
  • if I copy a footrpint then run Footprint Editor, then delete the footprint and then ran Footprint Editor - everything is correct.

I’m happy that I know the way-around, but still I completelly don’t understand where from comes the libarary lists KiCad showes after I move footprint (out of KiCad).

I wonder if removing the fp-info-cache file from your project directory would remedy this. If so, I’m not sure how to force that file to be rebuilt short of removing it from the filesystem (or renaming it so KiCad doesn’t find it).

1 Like

Yes it does.
I am not doing any project now. I am just preparing my libs for future work. I have project opened only because KiCad don’t allow me for defining my libraries without opening any project (why! - I don’t understand).

My next step after my libs will be ready will be to define some PCBs without schematics. I am preparing such PCBs for any case we use. For example for DIN rail cases I mark in such PCB file regions where I can use high elements (electrolitics), regions where I have some more place under PCB (for example for toroid standing in rectangular whole), places where PCB there is the wall betwean terminal blocks and rest of PCB.
I’m not sure but suppose that will be impossible without makeing project.
Then I wonder that when I will have schematic ready (probably with another project) and then decide which case we will use how to merge these two projects into one.
I have never had such problems with my old Protel - there you just have no project files.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.