Where is the setting for dimension units

I have forgotten where the settings are for dimensions. Everything is in millimeters, but I still get inches.

What do you mean by “everything”?

Do you see these 3 buttons (6.0)?


Yes. I see them very well and board dimensions are still in inches.

I recorded this .gif with Licecap. I drew the board outline in inches and then switched to mm. (At that point after clicking on the board outline, I needed to drag the properties dialog box from my other monitor into the licecap window.) I then see its properties in mm. If this is not what you mean, can you record and post a .gif?


1 Like

I took a screen capture of what happened.

And I can change inches to mm later, but I wonder they are inches in beginning. This is a nightly build. Maybe this is a very bad version, because I have other problems too.
Edit: I made a new board, I think. Its dimension were in mm. I’ll go back to a backup PCB file.

Well you taught me something…I have never used the dimension tool (but I never needed it.)

Why don’t you go to help>about and copy paste your version information?

I am using 6.0. In my same demo I see that dimensions come out in mm (I am now in mm mode) even though I drew it initially in inches.

Application: KiCad PCB Editor (64-bit)

Version: (6.99.0-166-g1fccbdbd53), release build

wxWidgets 3.1.5
libcurl/7.78.0-DEV Schannel zlib/1.2.11

Platform: Windows 10 (build 19042), 64-bit edition, 64 bit, Little endian, wxMSW

Build Info:
Date: Dec 31 2021 09:01:20
wxWidgets: 3.1.5 (wchar_t,wx containers)
Boost: 1.76.0
OCC: 7.5.0
Curl: 7.78.0-DEV
ngspice: 35
Compiler: Visual C++ 1929 without C++ ABI

Build settings:

OK; regarding your version…I do not want to “go there” right now. Maybe in a few months…

Yes, I understand and agree. I accidentally saved my project in to V6.99 and can’t go back. But luckily there are backups. I hope not too old.

I have a couple of boards on order from JLCPCB. My desktop computer runs Win10 and (I am a newbie with Linux) but my 2008 vintage lab computer now has Linux Mint. I had to fight with Linux generally and to get compatible versions of KiCad in the two computers. So if I were to upgrade either one now I might make problems for myself. I would rather wait at least until I have got those boards built. By that time some of the larger bugs in 6.99 might be ironed out.

And you can’t go back from V6.99, so there must be good reason to go there.
By the way, I got also boards from JLCPCB, 5 little Atmega2560 boards. Now I have get this project ready before I can go playing with them.

Maybe you have to press a Redraw (or a Refresh screen) button after switching to different units. I don’t know. I haven’t used a newer version than 5.0.2. Maybe you found a bug! Did you try first giving another viewport input focus (occulting the pcbnew viewport) and then switching back to the pcbnew viewport ?

But units change ok, there are no problems, there are no problems in there. But the Units are wrong when I make a new , dimensions are in inches allthough I have all settings in mm.
I made a new measurement, all settings are probably metric (in millimeters) but I get inches.

1 Like

Great! you discovered a bug! Congratulations!

Have you also changed:
Pcbnew / File / Board Setup / Text & Graphics / Defaults / Defaults for dimension Objects / Units


Good. I have to check that too. It is so well hidden that I have not seen it.

That made it. It is working now, thank you.


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.