What's up with the KiCAD Linux (ppa) repository?

Just ran an update on my system and got this error message:

E: Repository ‘http://ppa.launchpad.net/js-reynaud/kicad-5.1/ubuntu focal InRelease’ changed its ‘Label’ value from ‘PPA for KiCad: 5.1 releases’ to ‘Legacy PPA for KiCad: 5.1 releases’

What’s up?
I’ve not been informed of new releases or other changes 'till now.

I also run Linux (Mint), but I’m not too well versed in this versioning stuff.
I’m currently running KiCad V5.1.6, and about a week or so ago V5.1.7 was released for Windows. A quick check on kicad-pcb.org suggest V5.1.7 is also already available for Debian. For Ubuntu there is no mention yet of V5.1.7. I have not checked the others.

I’m not sure if this is related it may be that someone is currently working on the updates to V5.1.7 for Ubuntu.

Also see this release note for 2020-09-30:

I think this is the official Ubuntu PPA repository now: https://launchpad.net/~kicad/+archive/ubuntu/kicad-5.1-releases as explained by https://kicad-pcb.org/download/ubuntu/ (slightly behind, talks about 5.1.6) I see 5.1.7 in the PPA. Same author, jsreynaud, just an official place to publish now.

I’m not sure how one would go about informing all users of an old PPA that it’s superseded except by a label change like you saw, since using a PPA is voluntary and involves no registration.

We tried. :man_shrugging:

3 Likes

sudo apt update

currently gives me:

E: Repository 'http://ppa.launchpad.net/kicad/kicad-5.1-releases/ubuntu focal InRelease' changed its 'Label' value from 'WIP: Don't use yet !! PPA for KiCad: 5.1 releases' to 'PPA for KiCad: 5.1 releases'
N: This must be accepted explicitly before updates for this repository can be applied. See apt-secure(8) manpage for details.
E: Failed to fetch http://ppa.launchpad.net/kicad/kicad-5.1-releases/ubuntu/dists/focal/InRelease  

This: https://kicad-pcb.org/download/ubuntu/ also explicitly mentions V5.1.6, but no V5.1.7 (Yet).

At this moment it’s bed time for me. Not in the mood to concentrate on it. Maybe tomorrow…

[Edit / Update]:
Not exactly sober at the moment, but in somewhat of a bold mood. So, again:

paul@medion:~$ sudo apt update
E: Repository 'http://ppa.launchpad.net/kicad/kicad-5.1-releases/ubuntu focal InRelease' changed its 'Label' value from 'WIP: Don't use yet !! PPA for KiCad: 5.1 releases' to 'PPA for KiCad: 5.1 releases'
N: This must be accepted explicitly before updates for this repository can be applied. See apt-secure(8) manpage for details.
Do you want to accept these changes and continue updating from this repository? [y/N] y
...
Fetched 27,2 kB in 29s (932 B/s)                                                                                                       
Reading package lists... Done
Building dependency tree       
Reading state information... Done
8 packages can be upgraded. Run 'apt list --upgradable' to see them.

and then:

paul@medion:~$ sudo apt upgrade
Reading package lists… Done
Building dependency tree
Reading state information… Done
Calculating upgrade… Done
The following packages were automatically installed and are no longer required:
linux-headers-5.4.0-45 linux-headers-5.4.0-45-generic linux-image-5.4.0-45-generic linux-modules-5.4.0-45-generic
linux-modules-extra-5.4.0-45-generic
Use ‘sudo apt autoremove’ to remove them.
The following packages will be upgraded:
kicad kicad-demos kicad-doc-en kicad-footprints kicad-libraries kicad-packages3d kicad-symbols kicad-templates
8 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 428 MB of archives.
After this operation, 124 MB of additional disk space will be used.
Do you want to continue? [Y/n] y
Get:1 http://ppa.launchpad.net/kicad/kicad-5.1-releases/ubuntu focal/main amd64 kicad amd64 5.1.7-202009280730+a382d34a8~87~ubuntu20.04.1 [22,9 MB]
Get:2 http://ppa.launchpad.net/kicad/kicad-5.1-releases/ubuntu focal/main amd64 kicad-demos all 5.1.7-202009280730+a382d34a8~87~ubuntu20.04.1 [987 kB]
Get:3 http://ppa.launchpad.net/kicad/kicad-5.1-releases/ubuntu focal/main amd64 kicad-doc-en all 5.1.7-202009280733+1685~27~ubuntu20.04.1 [25,8 MB]
Get:4 http://ppa.launchpad.net/kicad/kicad-5.1-releases/ubuntu focal/main amd64 kicad-footprints all 5.1.7-202009280734+302ac78b~10~ubuntu20.04.1 [2.724 kB]
Get:5 http://ppa.launchpad.net/kicad/kicad-5.1-releases/ubuntu focal/main amd64 kicad-libraries all 5.1.7-202009280737+7~ubuntu20.04.1 [1.408 B]
Get:6 http://ppa.launchpad.net/kicad/kicad-5.1-releases/ubuntu focal/main amd64 kicad-packages3d all 5.1.7-202009280742+7abe02f3~7~ubuntu20.04.1 [373 MB]
Get:7 http://ppa.launchpad.net/kicad/kicad-5.1-releases/ubuntu focal/main amd64 kicad-symbols all 5.1.7-202009280741+bf475af9~6~ubuntu20.04.1 [1.164 kB]
Get:8 http://ppa.launchpad.net/kicad/kicad-5.1-releases/ubuntu focal/main amd64 kicad-templates all 5.1.7-202009280742+1ccbaf3~8~ubuntu20.04.1 [1.400 kB]
Fetched 428 MB in 1min 5s (6.618 kB/s)
(Reading database … 507384 files and directories currently installed.)
Preparing to unpack …/0-kicad_5.1.7-202009280730+a382d34a8~87~ubuntu20.04.1_amd64.deb …
Unpacking kicad (5.1.7-202009280730+a382d34a8~87~ubuntu20.04.1) over (5.1.6-202007171535+c6e7f7d~87~ubuntu20.04.1) …
Preparing to unpack …/1-kicad-demos_5.1.7-202009280730+a382d34a8~87~ubuntu20.04.1_all.deb …
Unpacking kicad-demos (5.1.7-202009280730+a382d34a8~87~ubuntu20.04.1) over (5.1.6-202007171535+c6e7f7d~87~ubuntu20.04.1) …
Preparing to unpack …/2-kicad-doc-en_5.1.7-202009280733+1685~27~ubuntu20.04.1_all.deb …
Unpacking kicad-doc-en (5.1.7-202009280733+1685~27~ubuntu20.04.1) over (5.1.6-202007171535+1684~27~ubuntu20.04.1) …
Preparing to unpack …/3-kicad-footprints_5.1.7-202009280734+302ac78b~10~ubuntu20.04.1_all.deb …
Unpacking kicad-footprints (5.1.7-202009280734+302ac78b~10~ubuntu20.04.1) over (5.1.6-202007171532+a61b4e4~10~ubuntu20.04.1) …
Preparing to unpack …/4-kicad-libraries_5.1.7-202009280737+7~ubuntu20.04.1_all.deb …
Unpacking kicad-libraries (5.1.7-202009280737+7~ubuntu20.04.1) over (5.1.6-202007171522+7~ubuntu20.04.1) …
Preparing to unpack …/5-kicad-packages3d_5.1.7-202009280742+7abe02f3~7~ubuntu20.04.1_all.deb …
Unpacking kicad-packages3d (5.1.7-202009280742+7abe02f3~7~ubuntu20.04.1) over (5.1.6-202007171539+150ff1c~7~ubuntu20.04.1) …
Preparing to unpack …/6-kicad-symbols_5.1.7-202009280741+bf475af9~6~ubuntu20.04.1_all.deb …
Unpacking kicad-symbols (5.1.7-202009280741+bf475af9~6~ubuntu20.04.1) over (5.1.6-202007171527+5150eaa~6~ubuntu20.04.1) …
Preparing to unpack …/7-kicad-templates_5.1.7-202009280742+1ccbaf3~8~ubuntu20.04.1_all.deb …
Unpacking kicad-templates (5.1.7-202009280742+1ccbaf3~8~ubuntu20.04.1) over (5.1.6-202007171519+9213d43~8~ubuntu20.04.1) …
Setting up kicad-footprints (5.1.7-202009280734+302ac78b~10~ubuntu20.04.1) …
Setting up kicad-packages3d (5.1.7-202009280742+7abe02f3~7~ubuntu20.04.1) …
Setting up kicad-demos (5.1.7-202009280730+a382d34a8~87~ubuntu20.04.1) …
Setting up kicad-templates (5.1.7-202009280742+1ccbaf3~8~ubuntu20.04.1) …
Setting up kicad-symbols (5.1.7-202009280741+bf475af9~6~ubuntu20.04.1) …
Setting up kicad (5.1.7-202009280730+a382d34a8~87~ubuntu20.04.1) …
Setting up kicad-doc-en (5.1.7-202009280733+1685~27~ubuntu20.04.1) …
Setting up kicad-libraries (5.1.7-202009280737+7~ubuntu20.04.1) …
Processing triggers for mime-support (3.64ubuntu1) …
Processing triggers for hicolor-icon-theme (0.17-2) …
Processing triggers for libc-bin (2.31-0ubuntu9.1) …
Processing triggers for shared-mime-info (1.15-1) …
Processing triggers for desktop-file-utils (0.24+linuxmint1) …

.
This took a few minutes to run. After that KiCad now starts with:

Application: KiCad
Version: 5.1.7-a382d34a8~87~ubuntu20.04.1, release build
Libraries:
wxWidgets 3.0.4
libcurl/7.68.0 OpenSSL/1.1.1f zlib/1.2.11 brotli/1.0.7 libidn2/2.2.0 libpsl/0.21.0 (+libidn2/2.2.0) libssh/0.9.3/openssl/zlib nghttp2/1.40.0 librtmp/2.3
Platform: Linux 5.4.0-48-generic x86_64, 64 bit, Little endian, wxGTK
Build Info:
wxWidgets: 3.0.4 (wchar_t,wx containers,compatible with 2.8) GTK+ 3.24
Boost: 1.71.0
OpenCASCADE Community Edition: 6.9.1
Curl: 7.68.0
Compiler: GCC 9.3.0 with C++ ABI 1013

Build settings:
USE_WX_GRAPHICS_CONTEXT=OFF
USE_WX_OVERLAY=ON
KICAD_SCRIPTING=ON
KICAD_SCRIPTING_MODULES=ON
KICAD_SCRIPTING_PYTHON3=ON
KICAD_SCRIPTING_WXPYTHON=ON
KICAD_SCRIPTING_WXPYTHON_PHOENIX=ON
KICAD_SCRIPTING_ACTION_MENU=ON
BUILD_GITHUB_PLUGIN=ON
KICAD_USE_OCE=ON
KICAD_USE_OCC=OFF
KICAD_SPICE=ON

So Cheers to y’all and I’m signing of for the day.

I’m very concerned that the jsrenaud PPA is right now being used for injecting malicious code into Linux/Ubuntu installations. I’ve been fighting with PC crashes (not just KiCAD, but boot failures) and reinstallations since two days, and they’re all related to the PPA.
Something’s gone horribly wrong here.

It is not. These are automatic builds based on the code visible in the repository. The js-reynaud repository pulls the build recipe directly from the main ~kicad repository.

You don’t need to believe me, this is open source and you can see this yourself at https://code.launchpad.net/~js-reynaud/+recipe/kicad5dev

Sounds like a hardware problem.

I’ve never heard of a widely used repo being used for injection attacks because of the amount of scrutiny the repos face.

The event-stream incident is rather notorious. But these sorts of attacks rely on maintainer burnout. Here, we simply moved the official repository.

I was having the same issues on both my Ubuntu desktops. Was on 5.1.6 and also got the same error when trying to upgrade.

Solved it by

rm /etc/apt/sources.list.d/kicad*
sudo apt-get update
sudo add-apt-repository --yes ppa:kicad/kicad-5.1-releases
sudo apt-get update
sudo apt-get dist-upgrade