What went wrong?

Hello, I’m still learning. Could someone help me out with this? I can’t seem to figure out what I’m doing wrong. I can see the symbols on my pc but their not loading in the software. And I keep getting this.

load error

Sorry in advance I know this has most likely been asked before and I appreciate the help.

KiCad is telling you it can not find a Library for footprints. That means the library is listed in Project Manager / Preferences / Manage Footprint Libraries (It can be either a Global or (more likely) a Project Specific library, but the library itself is not found in the specific location. It could be that the library is not used or needed at all, in that case you can remove the entry from the library table. Or (If the library is used) the project is not complete and the library itself has to be added, or there is a miss- spelling in the library name or location that has to be fixed.

The path component ${Extras\ScottoKicad} looks odd. what are you trying to do with that? Do you have an environment variable called Extras\ScottoKiCad?

Welcome @Esco

Rather than what went wrong, it would be better if you could explain what you are trying to do and how you are going about it.

Where did you find the symbol?
Did you create the library?
Did you place the symbol in the library?
How did you place that library into Kicad?

Perhaps . . .

Yeah, maybe; but those library paths won’t be recognised by Kicad.

Something is amiss with the OP’s workflow in importing both the symbol and footprint, no matter which version of Kicad the OP is using on whatever Operating System.

More information will help us guide, instead of confuse, the OP. :slightly_smiling_face:

Maybe the OP Tried to import the Footprints as a Schematic library . . . hence


And tried to import a 3 year old library instead of creating libraries and importing the symbols and footprints.
I don’t see any library files ending in .pretty or kicad_sym.

And what’s more, KiCad doesn’t even allow creating that kind of path variable. The dialog accepts only capital letters, numbers and _ .

I can only guess he wanted ${Extras}\ScottoKicad\work flow.…etc.
I would also avoid spaces in file and directory names. Never helps.

I just hope, after this onslaught of comments, that the OP is willing to raise their head above the parapet and type, so we can offer guidance. :innocent:

I was looking to make a PCB for a keyboard. I didn’t type KiCad. i just copied and downloaded the files. I was following a guide by ai03 and got to the Molex and then the error notice. right now I’m going back through the tutorials to see if I’ve made any mistakes.

It is possible (likely?) that those libraries are not mentioned in the tutorial at all (do a search). Once you have your (custom) libraries setup, it is easy to forget if you make a tutorial weeks or months later. But those libraries should be part of the project, and once you have learned how library management works in KiCad, it is quite easy to fix.

Another way is to create a project specific library with PCB Editor / File / Export / Footprints to New Library. If you do this, then:

  1. Make it a project specific library.
  2. Accept the suggestion from KiCad to update the footprints on the PCB.
  3. Use PCB Editor / Tools / Update Schematic from PCB (the other way around from the usual workflow!) to push these library changes back to the schematic.

And of course, make regular backups. This gives you ease of mind while experimenting with functions you do not (yet) fully understand.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.