What does "Mouse drag behavior" do?

I’m talking about this setting:


The dialog can be reached by selecting the Route tracks tool, right-clicking an empty area and choosing Interactive Router Settings.

The available options are “Move item” and “Interactive drag”, but I couldn’t figure out what difference they make.

Interesting question. It doesn’t seem to be documented in the manual for either 5.1 or 5.99.

I’m playing around with it in 5.99 and I don’t notice a difference either way, but I may not be doing the right thing.

I was expecting it to do the same thing as “Mouse drag track behavior” in Preferences -> PCB Editor -> Editing Options (location/language might be different in 5.1). :man_shrugging:

I did not have much trouble figuring this out.

It becomes clear when you first click on a track segment, and then drag it while keeping the mouse button depressed.

  • “Move” moves the selected track segment (which disconnects it from adjacent tracks).
  • “Interactive Drag” keeps the track segment attached to other track segments.
1 Like

Ok, I see the difference now. It basically controls if a click-and-drag operation (when the Select item tool is active!) is equivalent to a grab or a move.

The confusing thing is that the setting is in the Interactive Router Settings dialog which can only be reached from the Route tracks menu but the setting itself only has an effect when the Route tracks mode is not active.

That setting decides if dragging track using mouse uses Interactive Router or not so I see nothing wrong to set in Interactive Router Settings if that settings are also used when you use mouse at track.

That’s what I was expecting to happen, but it’s not what I actually see. The setting in preferences (Preferences -> PCB Editor -> Editing Options -> Track Mouse Drag Behavior) seems to be honored, but the router settings one is ignored for me?

Even if it worked, the UX isn’t great here. You can only get to this setting when you have the router tool activated, but the setting only matters when the router tool is inactive. My feeling is this setting should be removed; it’s already duplicated with the preferences option and they aren’t kept in sync. Also, the preferences option has 3 states (move, 45deg drag, free angle drag) but the router settings option only has 2…

I haven’t tried in 5.1, maybe it works properly there. It works in 5.1, not in 5.99 (for me)

Application: KiCad PCB Editor

Version: (5.99.0-12934-ge950278637), release build

	wxWidgets 3.0.5
	libcurl/7.79.1 OpenSSL/1.1.1l zlib/1.2.11 brotli/1.0.9 zstd/1.5.0 libidn2/2.3.2 libpsl/0.21.1 (+libidn2/2.3.0) libssh2/1.9.0 nghttp2/1.45.0

Platform: Linux 5.10.72-1-lts x86_64, 64 bit, Little endian, wxGTK, KDE, x11

Build Info:
	Date: Oct 23 2021 18:40:58
	wxWidgets: 3.0.5 (wchar_t,wx containers,compatible with 2.8) GTK+ 3.24
	Boost: 1.76.0
	OCC: 7.5.0
	Curl: 7.79.1
	ngspice: 35
	Compiler: GCC 11.1.0 with C++ ABI 1016

Build settings:

You shouldn’t have to go into the router to change a setting that determines if the router will be used in some future situation, in my opinion.

Edit: I guess you can also get to it from the Router Menu -> Interactive Router Settings, without starting the router tool.

It’s a bug that it is still in that dialog, that’s why it’s not in the documentation :slight_smile:

Should I finish the bug report that I’ve half completed or will you take it from here? :slight_smile:

Edit: https://gitlab.com/kicad/code/kicad/-/issues/9444

Jon’s already fixed (and closed) the bug, so I think that’s “he’ll take it from here”. :wink:

I supposed OP is writing about 5.1 so the main question for me was how it works and not how it should work. Speaking about 5.99 is a different story.

He had the fix pushed 4 minutes after I submitted it. I’m just helping with your time-to-bug-fix metrics :slight_smile:


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.