What am I doing wrong? Can't Seem to Update Footprint on PCB (SOLVED)


#1

I made a change to a footprint. I can view it with the editor just fine.

I re-ran CvPCB and saved.

I re-ran Eeshchema and created a new NetList and saved.

I opened PCBNew, and ran the NetList, selected Timestamp, Replace, Discard … still the same old footprints.

What step am I missing? I must have fog for brains tonight.

Thanks.

ON EDIT: I did manually delete some github entries to stop CvPCB from throwing errors.

SOLVED: In the part number, I left out a digit when saving the new footprint.


#2

Hey Sprig,
couple of ways you can do it…

One way that works for me is if I am already working on the pcb then I will right click and select the footprint and choose to edit in footprint editor. You will now be able to change the footprint. Then when you have what you want you can look at the top of the editor and click on “Update footprint in current board”. Now this will only change the footprint in the current board, NOT in your footprint library. If you want to also save it to your personal footprint library (or any other lib. for that matter) then also choose “file” “set active lib” then “save footprint in active lib”

please understand once you are in the pcb editor what ever you do there will not be saved back to the net list, unless you reverse export the netlist (not exact steps)

For a small simple board I find it acceptable to do some footprint editing without saving back to my lib but if it is a better footprint design that I might want to use in the future then take the time to save it to your personal lib.

another method would be to close out of the pcb and go to the footprint editor and change the footprint, save it, then open the cvpcb and re-associate the schematic symbol to the newly edited footprint, then export the netlist and then open pcb and re-read the new netlist.

when you re-read the netlist PAY ATTENTION to the various check boxes in the netlist dialog and be sure you don’t delete or replace footprints you have already edited or changed.

hope this helps
dwight


#3

THANKS Dwight_m,

I still don’t know what to think.

Changing a parameter or two on the footprint re-running CvPCB might fix the issue that I am currently having.


#4

Sprig,

What did I miss? What “issue” are you having??
Is it that the wrong pins are connecting to other pins? if so, then while in the footprint editor, right click on the given pad and change/correct the pin numbers for each pad. (possibly that is not your problem)
I just had to do that very thing on my pcb… the footprint’s pin numbers did not match the schematic symbol.

elaborate more…

dwight


#5

Thanks Dwight_m for your assistance and the personal time you used to help me on this matter.

I was actually only changing the courtyard layer, and maybe THAT is the issue??

Or, do I actually have to CLOSE PcbNew?

I THOUGHT I was doing the same thing that I did with other changes, but whatever I was doing that night NEVER updated the footprint for the parts on the board layout.

I ended up deleting all the footprint/parts, all 7 of them… LOL, then re-running the NetList reader for PcbNew. I just wanted to see if there was an easier way in case I encountered the same problem with 100 parts.


#6

SOLVED: In the part number, I left out a digit when saving the new footprint.