Weird problem with v6

I have a couple of weird problems with version 6. In version 6.0.0, I edited the hotkeys, and changed ‘C’ back to Duplicate in ‘eeschema’. This worked, and I could continue using eeschema in a similar way to v5. When I downloaded 6.0.1, the hotkey ‘C’ no longer created a duplicate component, despite being assigned to ‘Duplicate’ in the hotkey menu.
Now that I have downloaded 6.0.2, I have an additional problem. In pcbnew, if I assign a new copper fill area, it shows as an outline only (short hatched diagonal lines around the edges). If I then edit the fill, and change ‘Remove Islands’ from ‘always’ to ‘below area limit’, and assign a value, say 6, to the ‘minimum island size’ field, the copper fill is then created as expected.
It gets weirder. I then re downloaded v6.0.0, and it exhibits the same behavior, despite the fact that it worked originally. This is on Windows 10, but I have the same problem on linux as well.
Existing fills behave normally, and are modified as expected when doing a DRC check.

This is normal behavior if the fill does not touch any footprint pads of the same net. This did not change in 6.x.

I deleted the ground plane on an existing board. I then recreated it over the whole board are, and the rats nest remained until I changed the remove islands parameter.

Without your project attached or at least a screenshot, it is hard to say exactly why, but by default, zones in KiCad do not fill if they do not make a connection to at least one pad on their assigned net. Changing the island removal setting means that the zone will now fill with isolated copper (i.e. not actually connected to your ground net)

I hear you, but I have been using Kicad for at least 15 years. This is completely unexpected behavior.

I don’t know what to say other than “it’s always been this way”. But, hard to debug what happened without seeing your design.

@kevint: Are you aware that a zone is not filled automatically directly after creation?. A zone is only filled:

  • on executing the “Fill Zones”-command (look for the hotkey-settings, or use the top main-menubar with Edit → Fill All zones)
  • on closing the “Copper zone properties” dialog if additionally the checkbox “Preferences–>Pcb Editor–>Editing options → Refill zones after Zone Properties dialog” is set

So it’s normal behaviour that a new created zone is not instantly filled.

regarding the “duplicate”-issue:
There are two different “Duplicate”-hotkeys in the preferences:

  • section common–>Duplicate
    this hotkey (standard hotkey: CTRL+D) is for duplicating items in board and schematic editor.
  • section Schematic Editor–>Duplicate Symbol: This hotkey is per standard not assigned. And I could not determine what functionality is associated with this hotkey

Thanks mf_ibfeew
You are indeed correct. I would imagine that most users would only create a fill if they want one, so surely the deferred behavior should be optional rather than default?
I was about to go back to v5, so thanks for your help.

Depending on the complexity of the board, zone filling can be very processor intensive task and may take a long time. Therefore the actual filling phase is not automatic by default.

1 Like

Let me add: touching objects is not enough, the fill must include some sort of reference point of the net objects ? This caused some confusion to me in the beginning.

Correct, the zone must include the anchor point of a pad that is on the same net. The anchor point is usually in the center (but can be off-center with some types of pad design). The anchor point is where the router will start drawing tracks if you try to route from the pad.

1 Like

Actually this was at least part-fixed in 5.1 or 6.0: pads have 5 anchor points (center of the hole, E, W, N and S).

We use the actual shapes in 6.99, if you want to play with the nightlies… :wink:


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.